summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-10-28 09:14:17 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-10-28 09:16:23 -0700
commit06789739f53acc5ca9e1d75d2a70a004123cf676 (patch)
tree2d196e690dda0fd95ebbca04cfbdf41e82382d40 /app-misc
parentsys-fs/nilfs-utils: drop 2.1.5-r2 (diff)
downloadgentoo-06789739f53acc5ca9e1d75d2a70a004123cf676.tar.gz
gentoo-06789739f53acc5ca9e1d75d2a70a004123cf676.tar.bz2
gentoo-06789739f53acc5ca9e1d75d2a70a004123cf676.zip
app-misc/binwalk: add 2.3.3, enable py3.10
also partially revert test result change https://github.com/ReFirmLabs/binwalk/issues/566 Closes: https://bugs.gentoo.org/820359 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/binwalk/Manifest1
-rw-r--r--app-misc/binwalk/binwalk-2.3.3.ebuild43
-rw-r--r--app-misc/binwalk/files/2.3.3-tests.patch12
3 files changed, 56 insertions, 0 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
index dc6ea2eca113..2013e4d87bb3 100644
--- a/app-misc/binwalk/Manifest
+++ b/app-misc/binwalk/Manifest
@@ -1,2 +1,3 @@
DIST binwalk-2.2.0.tar.gz 39594514 BLAKE2B 899a919647258759f16c2e59766b0db68d1a78edf0f5c3755c2a987695199a1851deed2820e6323d82d8af85d294a6f1fcafb655e5d2257d49b673ddae49da67 SHA512 5f3ed31c0b5f9ca3057f86e82787a73b06f9f73747b51dd72130a78e4d69cf43a0207bffc495d177e97811de5bf835b3d0507f314b7a0c960eddf6d1efe0f0f9
DIST binwalk-2.3.1.tar.gz 39603558 BLAKE2B c3de5baaec18242d3db2b9492edadb3607a45fbc1237185223bf7bb04afcf0f8936607f9e0f4a99bd1796f5c7acfaef318855fe2c3ff05ae0676961bf60cc6c9 SHA512 3c9057c6f56d4bb1d604d3a361b0e682622a93d6d36c67a9f831ae7b17139c4684f52e96ce204d1d1256b79c4a3b806e7a78e2069b6c62eec188fa1586839670
+DIST binwalk-2.3.3.tar.gz 39723775 BLAKE2B d29b709dae0ae406e0ef6142e878a2bbbf0ddb3bd8f49d3335dd1e7ab385c331c021489b3d96b3c2364038b870c1aae53c8d82e7a3d9ab1983ff4520e20f6e73 SHA512 d7e8d576cfc92b1488ceda7d4577aeaaefb2a251a5aca0b4a497da0dff7c6e6e862e0a77346593c77fb4e54b7de3d3a0c1c8c9421ecec8f06aabbc4b336920c5
diff --git a/app-misc/binwalk/binwalk-2.3.3.ebuild b/app-misc/binwalk/binwalk-2.3.3.ebuild
new file mode 100644
index 000000000000..557b9217f689
--- /dev/null
+++ b/app-misc/binwalk/binwalk-2.3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/ReFirmLabs/binwalk.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ReFirmLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="A tool for identifying files embedded inside firmware images"
+HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
+
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-disable-test-coverage.patch
+ "${FILESDIR}"/2.3.3-tests.patch
+
+)
+
+distutils_enable_tests --install nose
+
+python_install_all() {
+ local DOCS=( API.md INSTALL.md README.md )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "binwalk has many optional dependencies to automatically"
+ elog "extract/decompress data, see INSTALL.md for more details."
+ fi
+}
diff --git a/app-misc/binwalk/files/2.3.3-tests.patch b/app-misc/binwalk/files/2.3.3-tests.patch
new file mode 100644
index 000000000000..dd4f876c7777
--- /dev/null
+++ b/app-misc/binwalk/files/2.3.3-tests.patch
@@ -0,0 +1,12 @@
+reverted:
+--- b/testing/tests/test_firmware_zip.py
++++ a/testing/tests/test_firmware_zip.py
+@@ -10,6 +10,8 @@
+ '''
+ expected_results = [
+ [0, 'Zip archive data, at least v1.0 to extract, name: dir655_revB_FW_203NA/'],
++ [51, 'Zip archive data, at least v2.0 to extract, compressed size: 6395868, uncompressed size: 6422554, name: dir655_revB_FW_203NA/DIR655B1_FW203NAB02.bin'],
++ [6395993, 'Zip archive data, at least v2.0 to extract, compressed size: 14243, uncompressed size: 61440, name: dir655_revB_FW_203NA/dir655_revB_release_notes_203NA.doc'],
+ [6410581, 'End of Zip archive, footer length: 22'],
+
+ ]