summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2021-10-26 19:17:32 +1100
committerMichael Palimaka <kensington@gentoo.org>2021-10-26 19:17:32 +1100
commit4060fb9c15888dc385584bdb056499c9f42f51b1 (patch)
tree1a5383f2ceebfaafebbeb9b61da0f17a35743224 /app-misc
parentapp-admin/bitwarden-desktop-bin: version bump 1.28.3 (diff)
downloadgentoo-4060fb9c15888dc385584bdb056499c9f42f51b1.tar.gz
gentoo-4060fb9c15888dc385584bdb056499c9f42f51b1.tar.bz2
gentoo-4060fb9c15888dc385584bdb056499c9f42f51b1.zip
app-misc/asciinema: version bump 2.1.0
Closes: https://bugs.gentoo.org/796017 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/asciinema/Manifest1
-rw-r--r--app-misc/asciinema/asciinema-2.1.0.ebuild24
-rw-r--r--app-misc/asciinema/files/asciinema-2.1.0-setuptools.patch23
3 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/asciinema/Manifest b/app-misc/asciinema/Manifest
index 1d8c559a252b..ff578f85c757 100644
--- a/app-misc/asciinema/Manifest
+++ b/app-misc/asciinema/Manifest
@@ -1 +1,2 @@
DIST asciinema-2.0.2.tar.gz 50058 BLAKE2B db04e21f41b76a7b2be1ca119b2c0a2ff29c9e525c35180d2506722b12c7d139087d0a102bd984cecd7d69e2da0ce8ac0f4bc83c631bc1373fecc8de2d29f107 SHA512 27ae831494c2532270940c3e0fedc87ebbdc1e9d8d24c37d1b63d3f74d9722d38e867fa1b46656249e5b0a84ed7ed32bb21da65f06e9c6a8b787aebdce2068f3
+DIST asciinema-2.1.0.tar.gz 82022 BLAKE2B 2f7c68caef228a6cb98f3503212edc393bd8f7a3653a369b0509d45a6e19b8373630fac88498a771c0eaa2a322a95ab816b268660b8b2384d1ec25c617b06a5a SHA512 df77ccea13e06e9c5feda22be2366aa702acf510fdc6cbc9a09b20d67ae43a47214891fbb5ef080ff9af9c3ee2f450694c306ee1dbdbdef3f9862dc6dee60750
diff --git a/app-misc/asciinema/asciinema-2.1.0.ebuild b/app-misc/asciinema/asciinema-2.1.0.ebuild
new file mode 100644
index 000000000000..895864b09a47
--- /dev/null
+++ b/app-misc/asciinema/asciinema-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Command line recorder for asciinema.org service"
+HOMEPAGE="https://asciinema.org/ https://pypi.org/project/asciinema/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-setuptools.patch" )
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i -e "s|data_files=\[('share/doc/asciinema|&-${PVR}|" setup.py || die
+}
diff --git a/app-misc/asciinema/files/asciinema-2.1.0-setuptools.patch b/app-misc/asciinema/files/asciinema-2.1.0-setuptools.patch
new file mode 100644
index 000000000000..5180f2760128
--- /dev/null
+++ b/app-misc/asciinema/files/asciinema-2.1.0-setuptools.patch
@@ -0,0 +1,23 @@
+From 014b1fead4c0130e14c99f54ed521d5d0535365a Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Tue, 26 Oct 2021 19:13:33 +1100
+Subject: [PATCH] setup.cfg: fix deprecated key usage
+
+---
+ setup.cfg | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.cfg b/setup.cfg
+index bbd4d8d..17afd12 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,5 +1,5 @@
+ [metadata]
+-description-file = README.md
++description_file = README.md
+ license_file = LICENSE
+
+ [pycodestyle]
+--
+2.32.0
+