summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2023-09-11 13:22:21 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-14 21:10:30 +0300
commit6853c98a74ca8383d641712c48503b7c4123ed32 (patch)
tree59e03a031cb8120be5008e3f63d8418364b52eb0 /app-misc
parentnet-analyzer/tcptrace: Fix call to undeclared function fpurge (diff)
downloadgentoo-6853c98a74ca8383d641712c48503b7c4123ed32.tar.gz
gentoo-6853c98a74ca8383d641712c48503b7c4123ed32.tar.bz2
gentoo-6853c98a74ca8383d641712c48503b7c4123ed32.zip
app-misc/regex-markup: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/722328 Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Closes: https://github.com/gentoo/gentoo/pull/32724 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/regex-markup/files/regex-markup-0.10.0-r2-configure.patch15
-rw-r--r--app-misc/regex-markup/regex-markup-0.10.0-r2.ebuild44
2 files changed, 59 insertions, 0 deletions
diff --git a/app-misc/regex-markup/files/regex-markup-0.10.0-r2-configure.patch b/app-misc/regex-markup/files/regex-markup-0.10.0-r2-configure.patch
new file mode 100644
index 000000000000..5ea8efa2834e
--- /dev/null
+++ b/app-misc/regex-markup/files/regex-markup-0.10.0-r2-configure.patch
@@ -0,0 +1,15 @@
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index 0b98557..3e24e2e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,6 +19,7 @@ AC_DEFINE_DIR(PKGDATADIR, datadir/$PACKAGE, [Directory where system-wide rule fi
+ # Checks for programs.
+ AC_PROG_CC
+ AC_PROG_INSTALL
++AM_PROG_AR
+ #AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
+ AM_PROG_LEX
diff --git a/app-misc/regex-markup/regex-markup-0.10.0-r2.ebuild b/app-misc/regex-markup/regex-markup-0.10.0-r2.ebuild
new file mode 100644
index 000000000000..5de67300b596
--- /dev/null
+++ b/app-misc/regex-markup/regex-markup-0.10.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="A tool to color syslog files as well"
+HOMEPAGE="http://www.nongnu.org/regex-markup/"
+SRC_URI="https://savannah.nongnu.org/download/regex-markup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples nls"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-locale.patch
+ "${FILESDIR}"/${PN}-0.10.0-r2-configure.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # fix #570960 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ local myconf=(
+ --enable-largefile
+ $(use_enable nls)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ if use examples; then
+ cd examples || die
+ emake -f Makefile
+ fi
+}