summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJannis Achstetter <kripton@kripserver.net>2024-04-08 22:51:47 +0200
committerMarek Szuba <marecki@gentoo.org>2024-06-12 14:04:01 +0100
commit8319838698e3d4c532c7a8547ebdc1ae5dcb2264 (patch)
tree3947e22eba972f03be3927da46993d30e0bf1d62 /app-misc
parentnet-misc/connman-gtk: stabilize 1.1.1-r2 for amd64 (diff)
downloadgentoo-8319838698e3d4c532c7a8547ebdc1ae5dcb2264.tar.gz
gentoo-8319838698e3d4c532c7a8547ebdc1ae5dcb2264.tar.bz2
gentoo-8319838698e3d4c532c7a8547ebdc1ae5dcb2264.zip
app-misc/ola: Fix compilation against media-libs/liblo-0.32
Changes to the PR made by marecki at merge time: - run ola-0.10.9-liblo.patch through scrub-patch - revert the revision bump as not needed while fixing build failures Closes: https://bugs.gentoo.org/927000 Upstream-PR: https://github.com/OpenLightingProject/ola/pull/1954 Upstream-Commit: https://github.com/OpenLightingProject/ola/commit/e083653d2d18018fe6ef42f757bc06462de87f28 Signed-off-by: Jannis Achstetter <kripton@kripserver.net> Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ola/files/ola-0.10.9-liblo.patch27
-rw-r--r--app-misc/ola/ola-0.10.9-r2.ebuild3
2 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/ola/files/ola-0.10.9-liblo.patch b/app-misc/ola/files/ola-0.10.9-liblo.patch
new file mode 100644
index 000000000000..ac80a2503d49
--- /dev/null
+++ b/app-misc/ola/files/ola-0.10.9-liblo.patch
@@ -0,0 +1,27 @@
+From e083653d2d18018fe6ef42f757bc06462de87f28 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Florian=20H=C3=BClsmann?= <fh@cbix.de>
+Date: Sat, 30 Mar 2024 12:43:55 +0100
+Subject: [PATCH] Fix liblo 0.32 header compatibility
+
+Closes: https://bugs.gentoo.org/927000
+Upstream-PR: https://github.com/OpenLightingProject/ola/pull/1954
+--- a/plugins/osc/OSCNode.cpp
++++ b/plugins/osc/OSCNode.cpp
+@@ -141,7 +141,7 @@ bool ExtractSlotValueFromPair(const string &type, lo_arg **argv,
+ * @param user_data a pointer to the OSCNode object.
+ */
+ int OSCDataHandler(const char *osc_address, const char *types, lo_arg **argv,
+- int argc, void *, void *user_data) {
++ int argc, lo_message, void *user_data) {
+ OLA_DEBUG << "Got OSC message for " << osc_address << ", types are " << types;
+
+ OSCNode *node = reinterpret_cast<OSCNode*>(user_data);
+@@ -150,7 +150,7 @@ int OSCDataHandler(const char *osc_address, const char *types, lo_arg **argv,
+
+ if (argc == 1) {
+ if (type == "b") {
+- lo_blob blob = argv[0];
++ lo_blob blob = (lo_blob)argv[0];
+ unsigned int size = min(static_cast<uint32_t>(DMX_UNIVERSE_SIZE),
+ lo_blob_datasize(blob));
+ node->SetUniverse(
diff --git a/app-misc/ola/ola-0.10.9-r2.ebuild b/app-misc/ola/ola-0.10.9-r2.ebuild
index a9d0c36ac512..1cd74bb29e17 100644
--- a/app-misc/ola/ola-0.10.9-r2.ebuild
+++ b/app-misc/ola/ola-0.10.9-r2.ebuild
@@ -61,8 +61,11 @@ BDEPEND="app-alternatives/yacc
)
)"
+# ola-0.10.9-liblo.patch fixes compilation against
+# media-libs/liblo-0.32. See https://bugs.gentoo.org/927000
PATCHES=(
"${FILESDIR}"/${PN}-0.10.9-nullptr.patch
+ "${FILESDIR}"/${PN}-0.10.9-liblo.patch
)
src_prepare() {