summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-25 20:38:25 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-08 13:51:12 +0200
commitc25cf375a239d5169779252065da56d8dea31996 (patch)
tree917d4e1753441bc011f9a99f30842c27859bb7ad /app-misc
parentapp-text/cherrytree: Remove old versions (diff)
downloadgentoo-c25cf375a239d5169779252065da56d8dea31996.tar.gz
gentoo-c25cf375a239d5169779252065da56d8dea31996.tar.bz2
gentoo-c25cf375a239d5169779252065da56d8dea31996.zip
app-misc/gnote: Version bump to 45.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33061 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-45.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 8393393fcf44..37f68afc9c70 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,2 +1,3 @@
DIST gnote-44.1.tar.xz 3330072 BLAKE2B ff86fa34bdfff61eceb25abef1c73377f888082e70e539172849bf9425eada1c11000c1a75f69eb74fdbc2fc6d45ad3c58c843bf769279a026dd5298a07abc68 SHA512 89364d161d6ecc11822b89dec0353d0e20bc08d883573f324e4980ff2420361ddeb326213eb668fba4ce8de7d5d9668a1a058666ad2b81658ef94f8a65b87363
+DIST gnote-45.0.tar.xz 3247716 BLAKE2B d3a31be5d9e84aaee4af5d22733e4bc14aaf844e31d488cbe9fb8d0b516815a3db5af00052a2a44c9cc07e2397a73b23cb036933c9b795caf54d1a156e0d16b9 SHA512 d06c128238d4f29d5bc0fb3bf3b1473000df5a4d860406ad0680b159cfacae259dd6dfbf6984e8772c3bcf485776e5ca423436f964c260594862949dcda2ea88
DIST gnote-45.rc.tar.xz 3273864 BLAKE2B 8ab5340e0659c4119c279dd1130fd1a591dd496c8eb96cbfe8171f02192a86a5a3cf6b8c075fd195373885271585c1e6ece1af8fdeb0b75442ddc911b29a7b6f SHA512 cb7b8b47ee724f206258b2dd72fb79c5da45c1f3bd1eca754adc57e8f6f9620a98c56d96867ed455511b78d6dac0d6ecac6968bb29e1964aeac233ff191c6072
diff --git a/app-misc/gnote/gnote-45.0.ebuild b/app-misc/gnote/gnote-45.0.ebuild
new file mode 100644
index 000000000000..62d3c9902709
--- /dev/null
+++ b/app-misc/gnote/gnote-45.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.74:2[dbus]
+ >=dev-cpp/glibmm-2.74:2.68
+ >=dev-cpp/gtkmm-4.0.0:4.0
+ >=app-crypt/libsecret-0.8
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16
+ test? ( dev-libs/unittest++ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Build system requires UnitTest++ >=1.5.1, but the .pc file doesn't
+ # specify a version
+ sed -i -e "/UnitTest++/ s/version: [^,]*,//" meson.build || die
+ if ! use test; then
+ sed -i -e "/unit_test_pp/ s/ = .*/ = disabler()/" meson.build || die
+ fi
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}