summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-16 15:33:13 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-24 10:36:47 +0100
commite065922601acf708006c45e22961ff01c67131c2 (patch)
treeb268cbbafd38b41505c7cf60bd6f48068e152844 /app-misc
parentapp-misc/ddcutil: add 2.0.0 (diff)
downloadgentoo-e065922601acf708006c45e22961ff01c67131c2.tar.gz
gentoo-e065922601acf708006c45e22961ff01c67131c2.tar.bz2
gentoo-e065922601acf708006c45e22961ff01c67131c2.zip
app-misc/ddcui: add 0.4.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/33847 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ddcui/Manifest1
-rw-r--r--app-misc/ddcui/ddcui-0.4.2.ebuild36
-rw-r--r--app-misc/ddcui/files/ddcui-0.4.2-drop-qthelp-dep.patch30
3 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/ddcui/Manifest b/app-misc/ddcui/Manifest
index 050bea05e702..f95e283a2f22 100644
--- a/app-misc/ddcui/Manifest
+++ b/app-misc/ddcui/Manifest
@@ -1,2 +1,3 @@
DIST ddcui-0.2.1.tar.gz 601220 BLAKE2B 18af4ee4db741a612565260ed812f7274695472e9dc6e32c6670efcbdaeafcac9b0b45e44d02188d23e0f379f57b062270ecad58bdcfa8e8c2bf99c2775b1dfe SHA512 0df363dbf17750e3920e0afc5fc29b42271bbf06dcf52cddf46f3660155c0954ee39e8e356e9caebe1a6a679ab0b3a4ebb2e501a9bb9ac2cd47da3f522fb3169
DIST ddcui-0.3.0.tar.gz 601534 BLAKE2B d91d7467879c684cbb8571da48dfd170afa60d63832b44515d6d19187792f6c3c2c178e907ad8693cdba8df44b448eb4393a91e4439dcda13ac096ad6e97a594 SHA512 fab1ea757aad90fa68d2f6f5c128d7917e81f287a0a9e432461c7b2119c3f0d9da0e28a013510d1b0cb300b40c3f4dd745f3e1732c52f671c4d6e39b3ef0c368
+DIST ddcui-0.4.2.tar.gz 613765 BLAKE2B 2479570d9a79c298d8823c8a658c190e230ec83afc1b1deb9e3659e723c30bd0f2c1d55bc0aa5dcdf975adbab5792afd8ef5d350247eef5710cee4c99f4b56a6 SHA512 7f4339d292e42feb5912570be3b5629d61433a51bfdf0197deb10f8c0bc0e568dbc72f8e117c82dade30f01e3f00b5e805c4458e2bf9e6cc5932e33b7e7e51aa
diff --git a/app-misc/ddcui/ddcui-0.4.2.ebuild b/app-misc/ddcui/ddcui-0.4.2.ebuild
new file mode 100644
index 000000000000..94f61da45cdd
--- /dev/null
+++ b/app-misc/ddcui/ddcui-0.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check for bumps & cleanup with app-misc/ddcutil
+
+inherit cmake xdg
+
+DESCRIPTION="Graphical user interface for ddcutil - control monitor settings"
+HOMEPAGE="https://www.ddcutil.com/ddcui_main/"
+SRC_URI="https://github.com/rockowitz/ddcui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib
+ >=app-misc/ddcutil-2.0.0:0/5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.4.2-drop-qthelp-dep.patch"
+)
+
+src_prepare() {
+ # move docs to correct dir
+ sed -i -e "s%share/doc/ddcui%share/doc/${PF}%g" CMakeLists.txt || die
+ cmake_src_prepare
+}
diff --git a/app-misc/ddcui/files/ddcui-0.4.2-drop-qthelp-dep.patch b/app-misc/ddcui/files/ddcui-0.4.2-drop-qthelp-dep.patch
new file mode 100644
index 000000000000..d7552b323ba1
--- /dev/null
+++ b/app-misc/ddcui/files/ddcui-0.4.2-drop-qthelp-dep.patch
@@ -0,0 +1,30 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aa68d60..522c9f3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -98,12 +98,11 @@ message( ${VERBOSE} " CMAKE_AUTORCC: ${CMAKE_AUTORCC}")
+
+ set(QT5_LIBRARIES Qt5::Widgets )
+ # Ensures all Qt componenets have same version:
+-find_package(Qt5 ${ddcui_qt_version} COMPONENTS Core Widgets Gui Help REQUIRED)
++find_package(Qt5 ${ddcui_qt_version} COMPONENTS Core Widgets Gui REQUIRED)
+ message( ${VERBOSE} "Qt directories:")
+ message( ${VERBOSE} " Qt5Widgets_INCLUDE_DIRS: ${Qt5Widgets_INCLUDE_DIRS}" )
+ message( ${VERBOSE} " Qt5Core_INCLUDE_DIRS: ${Qt5Core_INCLUDE_DIRS}" )
+ message( ${VERBOSE} " Qt5Gui_INCLUDE_DIRS: ${Qt5Gui_INCLUDE_DIRS}" )
+-message( ${VERBOSE} " Qt5Help_INCLUDE_DIRS: ${Qt5Help_INCLUDE_DIRS}" )
+
+ find_package (PkgConfig REQUIRED )
+ pkg_check_modules(GLIB2 REQUIRED glib-2.0>=${ddcui_glib_version})
+@@ -239,9 +238,9 @@ target_compile_options(ddcui PUBLIC "-fPIC" ${coverity_cflags})
+ # add_compile_options(-Og -H V=1)
+
+ # redundant: ${Qt5Gui_INCLUDE_DIRS} ${Qt5Core_INCLUDE_DIRS} ${Qt5Widgets_INCLUDE_DIRS}.
+-# ${Qt5Help_INCLUDE_DIRS} is a superset of them all
+ target_include_directories(ddcui SYSTEM PRIVATE
+- ${Qt5Help_INCLUDE_DIRS}
++ ${Qt5Gui_INCLUDE_DIRS}
++ ${Qt5Widgets_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIRS}
+ ${DDCUTIL_INCLUDE_DIRS})
+