summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-20 14:59:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-20 14:59:05 +0100
commitf7d95f28c2ba81e526811a6ea19354b6d8b0c667 (patch)
tree42e3638cec382ccfd44ca1ca462080de4dc90543 /app-misc
parentdev-libs/libgit2: x86 stable wrt bug #596758 (diff)
downloadgentoo-f7d95f28c2ba81e526811a6ea19354b6d8b0c667.tar.gz
gentoo-f7d95f28c2ba81e526811a6ea19354b6d8b0c667.tar.bz2
gentoo-f7d95f28c2ba81e526811a6ea19354b6d8b0c667.zip
app-misc/jira-cli: Filter deps from requirements
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/jira-cli/jira-cli-2.1.4-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/jira-cli/jira-cli-2.1.4-r1.ebuild b/app-misc/jira-cli/jira-cli-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..9a827af04f37
--- /dev/null
+++ b/app-misc/jira-cli/jira-cli-2.1.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Simple command line utility to interact with your jira instance"
+HOMEPAGE="https://github.com/alisaifee/jira-cli"
+SRC_URI="https://github.com/alisaifee/jira-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jira[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ >=dev-python/keyring-10.0.2-r1[${PYTHON_USEDEP}]
+ dev-python/keyrings_alt[${PYTHON_USEDEP}]"
+
+DEPEND="${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-4.0.3[${PYTHON_USEDEP}]
+ dev-python/hiro[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-1.7.4[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_prepare_all() {
+ sed -i -e '/ordereddict/d' -e '/argparse/d' requirements/main.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die
+}