summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-08-27 16:57:47 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-08-27 17:07:15 +0200
commitecf2e667c49b3265b5e2822a2b20aeb385042ac0 (patch)
tree8c3936d1c424e2c2b7eaac0b456c3d3405fdabdc /app-mobilephone
parentapp-mobilephone/heimdall: add 2.1.0 (diff)
downloadgentoo-ecf2e667c49b3265b5e2822a2b20aeb385042ac0.tar.gz
gentoo-ecf2e667c49b3265b5e2822a2b20aeb385042ac0.tar.bz2
gentoo-ecf2e667c49b3265b5e2822a2b20aeb385042ac0.zip
app-mobilephone/heimdall: sync live
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/heimdall/heimdall-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-mobilephone/heimdall/heimdall-9999.ebuild b/app-mobilephone/heimdall/heimdall-9999.ebuild
index 69599346a8bb..4869617d580c 100644
--- a/app-mobilephone/heimdall/heimdall-9999.ebuild
+++ b/app-mobilephone/heimdall/heimdall-9999.ebuild
@@ -1,22 +1,27 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake udev
+DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
+HOMEPAGE="
+ https://git.sr.ht/~grimler/Heimdall
+ https://glassechidna.com.au/heimdall/
+ https://github.com/Benjamin-Dobell/Heimdall
+"
+
if [[ ${PV} != 9999 ]]; then
SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64"
S="${WORKDIR}/Heimdall-v${PV}"
+
+ KEYWORDS="~amd64 ~arm64"
else
inherit git-r3
EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
fi
-DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
-HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
-
LICENSE="MIT"
SLOT="0"
IUSE="gui"
@@ -41,10 +46,9 @@ src_configure() {
}
src_install() {
- dobin "${BUILD_DIR}"/bin/heimdall
- use gui && dobin "${BUILD_DIR}"/bin/heimdall-frontend
+ cmake_src_install
+
udev_dorules heimdall/60-heimdall.rules
- dodoc README.md Linux/README
}
pkg_postinst() {