summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-21 12:00:21 +0100
committerAndreas K. Huettel <dilfridge@gentoo.org>2019-01-23 18:27:18 +0100
commit079a603ed47c4e77553c763eec879fb35b71bf71 (patch)
treec4e5de19e16f7b887d5872b91b8262c0f07aba6d /app-office/libreoffice
parentnet-dns/pdns-recursor: Cleanup (diff)
downloadgentoo-079a603ed47c4e77553c763eec879fb35b71bf71.tar.gz
gentoo-079a603ed47c4e77553c763eec879fb35b71bf71.tar.bz2
gentoo-079a603ed47c4e77553c763eec879fb35b71bf71.zip
app-office/libreoffice: Added "mariadb" USE flag
so users can choose between mariadb_config and mysql_config. Package-Manager: Portage-2.3.57, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/10879 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/libreoffice-6.2.9999.ebuild7
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild7
-rw-r--r--app-office/libreoffice/metadata.xml1
3 files changed, 11 insertions, 4 deletions
diff --git a/app-office/libreoffice/libreoffice-6.2.9999.ebuild b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
index c7a98fa7f096..55ece7a7600d 100644
--- a/app-office/libreoffice/libreoffice-6.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
@@ -63,7 +63,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
-googledrive gstreamer +gtk gtk2 kde odk pdfimport postgres test vlc
+googledrive gstreamer +gtk gtk2 kde +mariadb odk pdfimport postgres test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -102,7 +102,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
app-text/mythes
>=dev-cpp/clucene-2.3.3.4-r2
=dev-cpp/libcmis-0.5*
- dev-db/mysql-connector-c
dev-db/unixODBC
dev-lang/perl
dev-libs/boost:=[nls]
@@ -188,6 +187,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
)
libreoffice_extensions_scripting-beanshell? ( dev-java/bsh )
libreoffice_extensions_scripting-javascript? ( dev-java/rhino:1.6 )
+ mariadb? ( dev-db/mariadb-connector-c )
+ !mariadb? ( dev-db/mysql-connector-c )
pdfimport? ( app-text/poppler:=[cxx] )
postgres? ( >=dev-db/postgresql-9.0:*[kerberos] )
"
@@ -401,6 +402,7 @@ src_configure() {
--enable-randr
--enable-release-build
--disable-breakpad
+ --disable-bundle-mariadb
--disable-ccache
--disable-dependency-tracking
--disable-epm
@@ -490,6 +492,7 @@ src_configure() {
is-flagq "-flto*" && myeconfargs+=( --enable-lto )
+ MARIADBCONFIG="$(type -p $(usex mariadb mariadb mysql)_config)" \
econf "${myeconfargs[@]}"
}
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index c7a98fa7f096..55ece7a7600d 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -63,7 +63,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
-googledrive gstreamer +gtk gtk2 kde odk pdfimport postgres test vlc
+googledrive gstreamer +gtk gtk2 kde +mariadb odk pdfimport postgres test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -102,7 +102,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
app-text/mythes
>=dev-cpp/clucene-2.3.3.4-r2
=dev-cpp/libcmis-0.5*
- dev-db/mysql-connector-c
dev-db/unixODBC
dev-lang/perl
dev-libs/boost:=[nls]
@@ -188,6 +187,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
)
libreoffice_extensions_scripting-beanshell? ( dev-java/bsh )
libreoffice_extensions_scripting-javascript? ( dev-java/rhino:1.6 )
+ mariadb? ( dev-db/mariadb-connector-c )
+ !mariadb? ( dev-db/mysql-connector-c )
pdfimport? ( app-text/poppler:=[cxx] )
postgres? ( >=dev-db/postgresql-9.0:*[kerberos] )
"
@@ -401,6 +402,7 @@ src_configure() {
--enable-randr
--enable-release-build
--disable-breakpad
+ --disable-bundle-mariadb
--disable-ccache
--disable-dependency-tracking
--disable-epm
@@ -490,6 +492,7 @@ src_configure() {
is-flagq "-flto*" && myeconfargs+=( --enable-lto )
+ MARIADBCONFIG="$(type -p $(usex mariadb mariadb mysql)_config)" \
econf "${myeconfargs[@]}"
}
diff --git a/app-office/libreoffice/metadata.xml b/app-office/libreoffice/metadata.xml
index 103556859a03..6b514662f9ab 100644
--- a/app-office/libreoffice/metadata.xml
+++ b/app-office/libreoffice/metadata.xml
@@ -14,6 +14,7 @@ version</longdescription>
<flag name="coinmp">Use sci-libs/coinor-mp as alternative solver</flag>
<flag name="googledrive">Enable support for remote files on Google Drive</flag>
<flag name="gtk2">Enable legacy gtk2 frontend</flag>
+ <flag name="mariadb">Prefer mariadb connector over mysql connector</flag>
<flag name="odk">Build the Office Development Kit</flag>
<flag name="pdfimport">Enable PDF import via the Poppler library</flag>
<flag name="vlc">Use <pkg>media-video/vlc</pkg> for video embedding</flag>