summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-18 04:32:27 +0100
committerSam James <sam@gentoo.org>2022-10-18 04:34:31 +0100
commit8f31c465f297c4032ad0cd1311bf1f2a183229aa (patch)
tree9d1a58790fa63c0db76cc33668f21187120e9645 /app-portage/layman
parentapp-backup/spideroak-bin: don't call doman on compressed file (diff)
downloadgentoo-8f31c465f297c4032ad0cd1311bf1f2a183229aa.tar.gz
gentoo-8f31c465f297c4032ad0cd1311bf1f2a183229aa.tar.bz2
gentoo-8f31c465f297c4032ad0cd1311bf1f2a183229aa.zip
app-portage/layman: add asciidoc BDEPEND for live
Closes: https://bugs.gentoo.org/676958 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage/layman')
-rw-r--r--app-portage/layman/layman-2.4.3.ebuild10
-rw-r--r--app-portage/layman/layman-9999.ebuild10
2 files changed, 12 insertions, 8 deletions
diff --git a/app-portage/layman/layman-2.4.3.ebuild b/app-portage/layman/layman-2.4.3.ebuild
index 241864865100..eed4b3067dc7 100644
--- a/app-portage/layman/layman-2.4.3.ebuild
+++ b/app-portage/layman/layman-2.4.3.ebuild
@@ -25,9 +25,7 @@ SLOT="0"
IUSE="cvs darcs +git gpg g-sorcery mercurial sqlite squashfs subversion sync-plugin-portage test"
RESTRICT="!test? ( test )"
-DEPEND="test? ( dev-vcs/subversion )
- "
-
+BDEPEND="test? ( dev-vcs/subversion )"
RDEPEND="
cvs? ( dev-vcs/cvs )
darcs? ( dev-vcs/darcs )
@@ -39,7 +37,11 @@ RDEPEND="
sync-plugin-portage? ( >=sys-apps/portage-2.2.16[${PYTHON_USEDEP}] )
!sync-plugin-portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
>=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
- "
+"
+
+if [[ ${PV} == *9999 ]]; then
+ BDEPEND+=" app-text/asciidoc"
+fi
layman_check_kernel_config() {
local CONFIG_CHECK
diff --git a/app-portage/layman/layman-9999.ebuild b/app-portage/layman/layman-9999.ebuild
index 9045c9189761..49649b33a171 100644
--- a/app-portage/layman/layman-9999.ebuild
+++ b/app-portage/layman/layman-9999.ebuild
@@ -25,9 +25,7 @@ SLOT="0"
IUSE="cvs darcs +git gpg g-sorcery mercurial sqlite squashfs subversion sync-plugin-portage test"
RESTRICT="!test? ( test )"
-DEPEND="test? ( dev-vcs/subversion )
- "
-
+BDEPEND="test? ( dev-vcs/subversion )"
RDEPEND="
cvs? ( dev-vcs/cvs )
darcs? ( dev-vcs/darcs )
@@ -39,7 +37,11 @@ RDEPEND="
sync-plugin-portage? ( >=sys-apps/portage-2.2.16[${PYTHON_USEDEP}] )
!sync-plugin-portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
>=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
- "
+"
+
+if [[ ${PV} == *9999 ]]; then
+ BDEPEND+=" app-text/asciidoc"
+fi
layman_check_kernel_config() {
local CONFIG_CHECK