summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-03 19:07:34 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-03 19:16:39 +0200
commitbc85a8e3b8e3a03dd992d76b8e7f6ff294f02eae (patch)
treecb15e6477313129e2bcf1ae25fde486b5be15a9d /app-portage/nattka
parentapp-leechcraft/lc-core: update to EAPI=7, reorganize deps (diff)
downloadgentoo-bc85a8e3b8e3a03dd992d76b8e7f6ff294f02eae.tar.gz
gentoo-bc85a8e3b8e3a03dd992d76b8e7f6ff294f02eae.tar.bz2
gentoo-bc85a8e3b8e3a03dd992d76b8e7f6ff294f02eae.zip
app-portage/nattka: Bump to 0.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/nattka')
-rw-r--r--app-portage/nattka/Manifest1
-rw-r--r--app-portage/nattka/nattka-0.0.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-portage/nattka/Manifest b/app-portage/nattka/Manifest
index 717e89de1995..0878e2844797 100644
--- a/app-portage/nattka/Manifest
+++ b/app-portage/nattka/Manifest
@@ -1 +1,2 @@
DIST nattka-0.0.1.tar.gz 30938 BLAKE2B 1338c5ef1d8cd9c09aaa4502bb94aa2fccabc3b4329ca35005c48f6317e6ae36d5ec9adbbd18a1f86bbe289c8505a0cd5db4159a202514772c3c266b98c60ab7 SHA512 245e6f5e0828c17a98111859a12de0f0401afa33755ed705ff93ecab8e57fa985f6f536b1f4855636a28d74366d924ef6d727e8933e1d01fc17caa8b4b6e5d2b
+DIST nattka-0.0.2.tar.gz 48458 BLAKE2B 56d20e62b9b56125562afc783ea1344fabb3b3743c1f50a10f6c9cf4f95c83081e7da88b67fbe2bbd3e79ec4542a1ef5bbc712bc644e8a8ab352dc30fd8a63f6 SHA512 186978d2131c686f07e7d193a2532a5b91b7fb389269ec97a5a23ac7e149451f40df6f4afa3be4a633d659ae4a923c62384b71861b5b9a674adffbb44ac67cdd
diff --git a/app-portage/nattka/nattka-0.0.2.ebuild b/app-portage/nattka/nattka-0.0.2.ebuild
new file mode 100644
index 000000000000..93d9d93ce65a
--- /dev/null
+++ b/app-portage/nattka/nattka-0.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-util/pkgcheck[${PYTHON_USEDEP}]
+ dev-vcs/git
+ sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest