summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2025-02-09 00:02:13 +0100
committerSebastian Pipping <sping@gentoo.org>2025-02-09 00:13:04 +0100
commit41bec03a73a465e62f2b6883024aee9951c20a6c (patch)
tree336b52afaeaf67095648447939a5888ab180ff4f /app-portage
parentsys-kernel/gentoo-sources: drop 6.12.10 (diff)
downloadgentoo-41bec03a73a465e62f2b6883024aee9951c20a6c.tar.gz
gentoo-41bec03a73a465e62f2b6883024aee9951c20a6c.tar.bz2
gentoo-41bec03a73a465e62f2b6883024aee9951c20a6c.zip
app-portage/elogv: 0.8.4 + Python 3.13
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elogv/Manifest1
-rw-r--r--app-portage/elogv/elogv-0.8.4.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-portage/elogv/Manifest b/app-portage/elogv/Manifest
index 914694aa721d..ec61b7d44f5f 100644
--- a/app-portage/elogv/Manifest
+++ b/app-portage/elogv/Manifest
@@ -1 +1,2 @@
DIST elogv-0.8.3.tar.gz 27144 BLAKE2B 7c672365afb9a17e2acf76f04b4479a5a9d8a43fd1e739ac86fb00f2744ad2b2871f12e3b384d292c8f7d704af877372e201644a6354b49d38d6ec03c2437f4d SHA512 9825e530f3e2de9f84aa77afba813aaba8ce68e3fb52f7685e98099e9f5a3b828cad259d4eb273aafba9b7a14ea9e41e9c0ecf2f6efe1dfd3b81f9ea0786592b
+DIST elogv-0.8.4.tar.gz 27342 BLAKE2B 6bfc4590fc26079c396c3db440b3402355e4e473dcf2ce5378c49c8ff8fd74540994e0f26f652541af9226c5911e65b6664c6743dcc19073b12b7db46d80cf3e SHA512 b648160ae89716ac0c4595138084d0a6fe0a546a022011e0682ec1b8cdcc570994d0ff3985a52a0eb11830246a6cc230344c370ab74ae6b023e8e657753f8b20
diff --git a/app-portage/elogv/elogv-0.8.4.ebuild b/app-portage/elogv/elogv-0.8.4.ebuild
new file mode 100644
index 000000000000..f6b9c433af25
--- /dev/null
+++ b/app-portage/elogv/elogv-0.8.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} pypy3 )
+PYTHON_REQ_USE="ncurses"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Curses based utility to parse the contents of elogs created by Portage"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elogv.git/"
+SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+PLOCALES=( "de" "es" "it" "pl" )
+IUSE="${PLOCALES[*]/#/l10n_}"
+
+RDEPEND="sys-apps/portage[${PYTHON_USEDEP}] ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+DOCS=( README )
+
+src_install() {
+ distutils-r1_src_install
+
+ elog 'Deleting unwanted language files...'
+ for i in ${PLOCALES[@]}; do
+ if use "l10n_${i}"; then
+ # Keep and fix man page filename (bug #869905)
+ mv "${ED}"/usr/share/man/${i}/man1/${PN}.1{.${i},} || die
+ else
+ rm -r "${ED}"/usr/share/{locale,man}/"${i}" || die
+ elog "- Language \"${i}\" deleted"
+ fi
+ done
+}
+
+pkg_postinst() {
+ elog "In order to use this software, you need to activate"
+ elog "Portage's elog features. Required is"
+ elog " PORTAGE_ELOG_SYSTEM=\"save\" "
+ elog "and at least one out of "
+ elog " PORTAGE_ELOG_CLASSES=\"warn error info log qa\""
+ elog "More information on the elog system can be found"
+ elog "in ${EPREFIX}/usr/share/portage/config/make.conf.example"
+ elog
+ elog "To operate properly this software needs the directory"
+ elog "${PORT_LOGDIR:-${EPREFIX}/var/log/portage}/elog created, belonging to group portage."
+ elog "To start the software as a user, add yourself to the portage"
+ elog "group."
+ elog
+}