summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-19 18:00:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-19 18:00:33 +0300
commit55eeb6a5ba70ddf28de0c5664e8d67d942e221de (patch)
tree77e6857a39cbf9f896ce5b91a40fe5b0938a221c /app-portage
parentmedia-libs/gstreamer-editing-services: Stabilize 1.22.11 x86, #928779 (diff)
downloadgentoo-55eeb6a5ba70ddf28de0c5664e8d67d942e221de.tar.gz
gentoo-55eeb6a5ba70ddf28de0c5664e8d67d942e221de.tar.bz2
gentoo-55eeb6a5ba70ddf28de0c5664e8d67d942e221de.zip
app-portage/golop: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/844637 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/golop/golop-0.2.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/golop/golop-0.2.1-r1.ebuild b/app-portage/golop/golop-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..ce8d84d8a050
--- /dev/null
+++ b/app-portage/golop/golop-0.2.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pure Go re-implementation of genlop"
+HOMEPAGE="https://github.com/klausman/golop"
+SRC_URI="https://github.com/klausman/golop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+src_compile() {
+ ego build -v -o ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+
+ local DOCS=( README.md )
+ einstalldocs
+}