summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2025-02-16 00:20:14 -0500
committerIonen Wolkens <ionen@gentoo.org>2025-02-16 00:24:18 -0500
commitbdc6b437e244987e3ca4deca61c5b185a8b2721c (patch)
tree2c43190c4a95c068eff510e116e77bf5f0feca37 /app-portage
parentsys-devel/gcc: add 14.2.1_p20250215 (diff)
downloadgentoo-bdc6b437e244987e3ca4deca61c5b185a8b2721c.tar.gz
gentoo-bdc6b437e244987e3ca4deca61c5b185a8b2721c.tar.bz2
gentoo-bdc6b437e244987e3ca4deca61c5b185a8b2721c.zip
app-portage/iwdevtools: add 0.12.15
Done straight-to-stable given only fixes outdated configs for Gentoo's pkgmoves, no code changes. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.15.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 23fda5181c61..808ae8706551 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.12.14.tar.gz 92477 BLAKE2B ed7291fd686400369a9a9ed8e8a35b310905a494486e65ee98787a746677e744b93070f0f6ebffee72d1da49297ab9c389e40207db1c318e47684bf2d44aef60 SHA512 06525fff14487619a4a7743d53ad49d904922fc955ea7f8d848f97818bb24ca15a56baa29ecb2ff935dc38140ce2e95b126078cf80bbb95c1f6cebd57d1bc6e3
+DIST iwdevtools-0.12.15.tar.gz 92500 BLAKE2B 3e106a9f4f1c6dc430d5ebb175d0269076d9f10e5ce7f61bae7f9a8816c2299e6eb5fd900644692b50fff6f775725d77eae7e700c074335a34e64e7ad3355bb0 SHA512 f5ffa9f8ef24f1015150555cfe9294a0ceb1726f1bde3401bc76bca102887cc0304616574097a7a27f1e485674a46afa3f9177d828046538d9279ea83d46bc37
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.15.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.15.ebuild
new file mode 100644
index 000000000000..eed608757c7e
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.15.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools/"
+SRC_URI="
+ https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1:0[readline]
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )
+"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}