summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-29 10:33:24 +0100
committerSam James <sam@gentoo.org>2022-04-29 11:20:40 +0100
commit4ccea6fe5d278ff7aeef1db79fa331a5ccfd1cf5 (patch)
tree7be05e0040c0fe43f668b0903b1732ca73546c95 /app-shells/dash
parentapp-shells/bash: drop 5.1_p8, 5.1_p12 (diff)
downloadgentoo-4ccea6fe5d278ff7aeef1db79fa331a5ccfd1cf5.tar.gz
gentoo-4ccea6fe5d278ff7aeef1db79fa331a5ccfd1cf5.tar.bz2
gentoo-4ccea6fe5d278ff7aeef1db79fa331a5ccfd1cf5.zip
app-shells/dash: drop 0.5.11.3-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/Manifest1
-rw-r--r--app-shells/dash/dash-0.5.11.3-r1.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
index ef0e3519c722..ebddbeec1dcc 100644
--- a/app-shells/dash/Manifest
+++ b/app-shells/dash/Manifest
@@ -1,2 +1 @@
-DIST dash-0.5.11.3.tar.gz 244507 BLAKE2B 06d4bd9f4c93e76ddf895f5a0ebca0c18d9554f5d4fd30a948eafc862db0f4cd523f623dad75969ddb5f510ac85d174f3b3aac3726f9d3ca8fbdb4377715b244 SHA512 ffe69b8de3586aba298d936168c329524e385252e12979aa1db28761e882048eb5a80673e93a2a2227f61b52fd8b56546b78c5db9c21a022072f536267f8bc20
DIST dash-0.5.11.5.tar.gz 240681 BLAKE2B 71c5e0acc127a01c75233b6d0a563979e5d856f16e3d108a68eb54d0b4b00f527f382e3e6aa963f9cff71bfaea2f524ba204ed04b7d006bd781784b2351e38c4 SHA512 5387e213820eeb44d812bb4697543023fd4662b51a9ffd52a702810fed8b28d23fbe35a7f371e6686107de9f81902eff109458964b4622f4c5412d60190a66bf
diff --git a/app-shells/dash/dash-0.5.11.3-r1.ebuild b/app-shells/dash/dash-0.5.11.3-r1.ebuild
deleted file mode 100644
index 6e0bed98e161..000000000000
--- a/app-shells/dash/dash-0.5.11.3-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Debian Almquist Shell"
-HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
-SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="libedit static"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
-DEPEND="${RDEPEND}
- libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.5.11.3-check_nflag_in_evaltree.patch" #754267
-)
-
-src_prepare() {
- default
-
- # Fix the invalid sort
- sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
-
- # Use pkg-config for libedit linkage
- sed -i \
- -e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \
- configure || die
-}
-
-src_configure() {
- if [[ ${CHOST} == *-solaris* ]] ; then
- # don't redefine stat, open, dirent, etc. on Solaris
- export ac_cv_func_stat64=yes
- export ac_cv_func_open64=yes
-
- # if your headers strictly adhere to POSIX, you'll need this too
- [[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
- fi
- if [[ ${CHOST} == powerpc-*-darwin* ]] ; then
- sed -i -e 's/= stpncpy(s, \([^,]\+\), \([0-9]\+\))/+= snprintf(s, \2, "%s", \1)/' \
- src/jobs.c || die
- fi
- append-cppflags -DJOBS=$(usex libedit 1 0)
- use static && append-ldflags -static
- # Do not pass --enable-glob due to #443552.
- local myeconfargs=(
- CC_FOR_BUILD="$(tc-getBUILD_CC)"
- --bindir="${EPREFIX}"/bin
- --enable-fnmatch
- $(use_with libedit)
- )
- econf "${myeconfargs[@]}"
-}