summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-08 23:50:33 +0000
committerSam James <sam@gentoo.org>2025-01-09 00:07:29 +0000
commit2fc310f411d8dbd4da03f31b7e473fdcf2fef626 (patch)
tree06dfc81a300a891ae052ee7f598be4ddf8e97ac1 /app-shells
parentapp-shells/bash: slot old (5.1) (diff)
downloadgentoo-2fc310f411d8dbd4da03f31b7e473fdcf2fef626.tar.gz
gentoo-2fc310f411d8dbd4da03f31b7e473fdcf2fef626.tar.bz2
gentoo-2fc310f411d8dbd4da03f31b7e473fdcf2fef626.zip
app-shells/bashdb: EAPI 8, adapt to slotted bash
bashdb releases tend to lag (significantly) behind bash releases, so the previous approach from bug #316611 where blockers were added on newer bash isn't really sustainable. Not least as configure aborts on any other bash version. Depend on slotted bash and pass --with-bash with the appropriate version. Bug: https://bugs.gentoo.org/316611 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bashdb/bashdb-5.0.1.1.2-r1.ebuild (renamed from app-shells/bashdb/bashdb-5.0.1.1.2.ebuild)23
1 files changed, 12 insertions, 11 deletions
diff --git a/app-shells/bashdb/bashdb-5.0.1.1.2.ebuild b/app-shells/bashdb/bashdb-5.0.1.1.2-r1.ebuild
index b773dc20f54e..f4018c58806a 100644
--- a/app-shells/bashdb/bashdb-5.0.1.1.2.ebuild
+++ b/app-shells/bashdb/bashdb-5.0.1.1.2-r1.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_P="${PN}-${PV:0:3}-${PV:4}"
DESCRIPTION="bash source code debugging"
HOMEPAGE="http://bashdb.sourceforge.net/"
-SRC_URI="https://downloads.sourceforge.net/bashdb/${MY_P}.tar.bz2
- test? ( mirror://gentoo/30/bashdb-4.4-1.0.0-missing-test-files.tar.xz )"
+SRC_URI="
+ https://downloads.sourceforge.net/bashdb/${MY_P}.tar.bz2
+ test? ( mirror://gentoo/30/bashdb-4.4-1.0.0-missing-test-files.tar.xz )
+"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
@@ -15,12 +18,8 @@ KEYWORDS="amd64 ppc ppc64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
- >=app-shells/bash-5
- !>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))
-"
-
-S="${WORKDIR}/${MY_P}"
+DEPEND="app-shells/bash:${PV:0:3}"
+RDEPEND="${DEPEND}"
src_prepare() {
if use test ; then
@@ -37,6 +36,8 @@ src_prepare() {
src_configure() {
# This path matches the bash sources. If we ever change bash,
- # we'll probably have to change this to match. #591994
- CONFIG_SHELL="${BROOT}"/bin/bash econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
+ # we'll probably have to change this to match (bug #591994).
+ CONFIG_SHELL="${BROOT}"/bin/bash econf \
+ --with-bash="${EPREFIX}"/bin/bash-${PV:0:3} \
+ --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
}