summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-27 12:16:37 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-27 12:56:04 -0800
commit6dedaa5efa9849ff40627490e39f01ca9a89298c (patch)
tree5ce113a8d141c6830c6734760f2dbae83dc625b4 /app-shells
parentapp-containers/cosign: fix makefile (diff)
downloadgentoo-6dedaa5efa9849ff40627490e39f01ca9a89298c.tar.gz
gentoo-6dedaa5efa9849ff40627490e39f01ca9a89298c.tar.bz2
gentoo-6dedaa5efa9849ff40627490e39f01ca9a89298c.zip
app-shells/autojump: Use mock from unittest
Closes: https://bugs.gentoo.org/831958 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/autojump/autojump-22.5.3-r1.ebuild6
-rw-r--r--app-shells/autojump/files/22.5.3-Use-mock-from-unittest.patch27
2 files changed, 32 insertions, 1 deletions
diff --git a/app-shells/autojump/autojump-22.5.3-r1.ebuild b/app-shells/autojump/autojump-22.5.3-r1.ebuild
index 6786cfcf9684..6c1430f5a0b7 100644
--- a/app-shells/autojump/autojump-22.5.3-r1.ebuild
+++ b/app-shells/autojump/autojump-22.5.3-r1.ebuild
@@ -29,8 +29,12 @@ DEPEND="${PYTHON_DEPS}
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${PV}-Use-mock-from-unittest.patch
+)
+
src_prepare() {
- eapply_user
+ default
sed -e "s:/usr/local/share:/usr/share:" \
-i bin/autojump.sh || die
diff --git a/app-shells/autojump/files/22.5.3-Use-mock-from-unittest.patch b/app-shells/autojump/files/22.5.3-Use-mock-from-unittest.patch
new file mode 100644
index 000000000000..942d19c838e0
--- /dev/null
+++ b/app-shells/autojump/files/22.5.3-Use-mock-from-unittest.patch
@@ -0,0 +1,27 @@
+https://github.com/wting/autojump/pull/648
+
+From b935baa9ab73305e0c8e3d733f40cc8567740020 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Thu, 27 Jan 2022 12:11:33 -0800
+Subject: [PATCH] Use mock from unittest
+
+---
+ tests/unit/autojump_utils_test.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/unit/autojump_utils_test.py b/tests/unit/autojump_utils_test.py
+index 07f67b3..386b4cd 100644
+--- a/tests/unit/autojump_utils_test.py
++++ b/tests/unit/autojump_utils_test.py
+@@ -3,7 +3,7 @@
+ import os
+ import sys
+
+-import mock
++from unittest import mock
+ import pytest
+
+ sys.path.append(os.path.join(os.getcwd(), 'bin')) # noqa
+--
+2.34.1
+