summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-30 03:25:24 +0100
committerSam James <sam@gentoo.org>2024-04-30 03:36:43 +0100
commitf7e98e17da6c3a9ddecad45d4d6ca5d51261db8a (patch)
tree20cdd7c72696172835c161dc62cd958bc5cbc324 /app-shells
parentapp-shells/bash: support -readline properly, GLOBSORT protection, misc cleanups (diff)
downloadgentoo-f7e98e17da6c3a9ddecad45d4d6ca5d51261db8a.tar.gz
gentoo-f7e98e17da6c3a9ddecad45d4d6ca5d51261db8a.tar.bz2
gentoo-f7e98e17da6c3a9ddecad45d4d6ca5d51261db8a.zip
app-shells/bash: drop shellcheck annotations; fix readline version
* Drop shellcheck annotations. We don't use them in ::gentoo right now. We might revisit that once shellcheck gains proper ebuild support, but right now, they serve as noise. * Fix readline version for <5.3_alpha. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-5.1_p16-r10.ebuild6
-rw-r--r--app-shells/bash/bash-5.2_p26-r3.ebuild6
-rw-r--r--app-shells/bash/bash-5.3_alpha-r2.ebuild4
-rw-r--r--app-shells/bash/bash-9999.ebuild4
4 files changed, 2 insertions, 18 deletions
diff --git a/app-shells/bash/bash-5.1_p16-r10.ebuild b/app-shells/bash/bash-5.1_p16-r10.ebuild
index 617706099afe..2f4a6284d0a0 100644
--- a/app-shells/bash/bash-5.1_p16-r10.ebuild
+++ b/app-shells/bash/bash-5.1_p16-r10.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# shellcheck shell=bash disable=2015,2034
EAPI=8
@@ -31,7 +30,7 @@ esac
# The version of readline this bash normally ships with. Note that we only use
# the bundled copy of readline for pre-releases.
-READLINE_VER="8.3_alpha"
+READLINE_VER="8.1"
DESCRIPTION="The standard GNU Bourne again shell"
HOMEPAGE="https://tiswww.case.edu/php/chet/bash/bashtop.html https://git.savannah.gnu.org/cgit/bash.git"
@@ -168,7 +167,6 @@ src_configure() {
# may misbehave at runtime.
unset -v YACC
- # shellcheck disable=2207
myconf=(
--disable-profiling
@@ -189,7 +187,6 @@ src_configure() {
# For descriptions of these, see config-top.h.
# bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
- # shellcheck disable=2046
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\""${EPREFIX}"/usr/local/sbin:"${EPREFIX}"/usr/local/bin:"${EPREFIX}"/usr/sbin:"${EPREFIX}"/usr/bin:"${EPREFIX}"/sbin:"${EPREFIX}"/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\""${EPREFIX}"/bin:"${EPREFIX}"/usr/bin:"${EPREFIX}"/sbin:"${EPREFIX}"/usr/sbin\"\' \
@@ -277,7 +274,6 @@ src_install() {
doexe "${@%.o}"
insinto /usr/include/bash-plugins
- # shellcheck disable=2035
doins *.h builtins/*.h include/*.h lib/{glob/glob.h,tilde/tilde.h}
fi
diff --git a/app-shells/bash/bash-5.2_p26-r3.ebuild b/app-shells/bash/bash-5.2_p26-r3.ebuild
index b4517186c6a1..3e1775504a62 100644
--- a/app-shells/bash/bash-5.2_p26-r3.ebuild
+++ b/app-shells/bash/bash-5.2_p26-r3.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# shellcheck shell=bash disable=2015,2034
EAPI=8
@@ -31,7 +30,7 @@ esac
# The version of readline this bash normally ships with. Note that we only use
# the bundled copy of readline for pre-releases.
-READLINE_VER="8.3_alpha"
+READLINE_VER="8.2_p1"
DESCRIPTION="The standard GNU Bourne again shell"
HOMEPAGE="https://tiswww.case.edu/php/chet/bash/bashtop.html https://git.savannah.gnu.org/cgit/bash.git"
@@ -175,7 +174,6 @@ src_configure() {
# may misbehave at runtime.
unset -v YACC
- # shellcheck disable=2207
myconf=(
--disable-profiling
@@ -196,7 +194,6 @@ src_configure() {
# For descriptions of these, see config-top.h.
# bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
- # shellcheck disable=2046
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\""${EPREFIX}"/usr/local/sbin:"${EPREFIX}"/usr/local/bin:"${EPREFIX}"/usr/sbin:"${EPREFIX}"/usr/bin:"${EPREFIX}"/sbin:"${EPREFIX}"/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\""${EPREFIX}"/bin:"${EPREFIX}"/usr/bin:"${EPREFIX}"/sbin:"${EPREFIX}"/usr/sbin\"\' \
@@ -327,7 +324,6 @@ src_install() {
doexe "${@%.o}"
insinto /usr/include/bash-plugins
- # shellcheck disable=2035
doins *.h builtins/*.h include/*.h lib/{glob/glob.h,tilde/tilde.h}
fi
diff --git a/app-shells/bash/bash-5.3_alpha-r2.ebuild b/app-shells/bash/bash-5.3_alpha-r2.ebuild
index aea9789a7642..f33bf717eac6 100644
--- a/app-shells/bash/bash-5.3_alpha-r2.ebuild
+++ b/app-shells/bash/bash-5.3_alpha-r2.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# shellcheck shell=bash disable=2015,2034
EAPI=8
@@ -174,7 +173,6 @@ src_configure() {
# upstream to Chet by email.
filter-lto
- # shellcheck disable=2207
myconf=(
--disable-profiling
@@ -195,7 +193,6 @@ src_configure() {
# For descriptions of these, see config-top.h.
# bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
- # shellcheck disable=2046
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\""${EPREFIX}"/usr/local/sbin:"${EPREFIX}"/usr/local/bin:"${EPREFIX}"/usr/sbin:"${EPREFIX}"/usr/bin:"${EPREFIX}"/sbin:"${EPREFIX}"/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\""${EPREFIX}"/bin:"${EPREFIX}"/usr/bin:"${EPREFIX}"/sbin:"${EPREFIX}"/usr/sbin\"\' \
@@ -326,7 +323,6 @@ src_install() {
doexe "${@%.o}"
insinto /usr/include/bash-plugins
- # shellcheck disable=2035
doins *.h builtins/*.h include/*.h lib/{glob/glob.h,tilde/tilde.h}
fi
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index 0acd12385e07..5c1278219ddb 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# shellcheck shell=bash disable=2015,2034
EAPI=8
@@ -174,7 +173,6 @@ src_configure() {
# upstream to Chet by email.
filter-lto
- # shellcheck disable=2207
myconf=(
--disable-profiling
@@ -195,7 +193,6 @@ src_configure() {
# For descriptions of these, see config-top.h.
# bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
- # shellcheck disable=2046
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\""${EPREFIX}"/usr/local/sbin:"${EPREFIX}"/usr/local/bin:"${EPREFIX}"/usr/sbin:"${EPREFIX}"/usr/bin:"${EPREFIX}"/sbin:"${EPREFIX}"/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\""${EPREFIX}"/bin:"${EPREFIX}"/usr/bin:"${EPREFIX}"/sbin:"${EPREFIX}"/usr/sbin\"\' \
@@ -326,7 +323,6 @@ src_install() {
doexe "${@%.o}"
insinto /usr/include/bash-plugins
- # shellcheck disable=2035
doins *.h builtins/*.h include/*.h lib/{glob/glob.h,tilde/tilde.h}
fi