summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-05-29 22:11:34 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-05-29 22:11:34 +0700
commit913499bdc8f25e75bc3bac9a7be0fc50bbf1750c (patch)
tree75812b288ab09c665dad42faa0f9af12fc278e38 /app-text/crwx-ng
parentnet-libs/libmicrohttpd: Stabilize 0.9.76 arm, #907351 (diff)
downloadgentoo-913499bdc8f25e75bc3bac9a7be0fc50bbf1750c.tar.gz
gentoo-913499bdc8f25e75bc3bac9a7be0fc50bbf1750c.tar.bz2
gentoo-913499bdc8f25e75bc3bac9a7be0fc50bbf1750c.zip
app-text/crwx-ng: DEPEND on wxGTk:3.2-gtk3
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/crwx-ng')
-rw-r--r--app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild b/app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild
new file mode 100644
index 000000000000..1042a5a774a0
--- /dev/null
+++ b/app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.2-gtk3"
+inherit cmake wxwidgets
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crwx-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+BDEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ virtual/ttf-fonts"
+
+PATCHES=( "${FILESDIR}"/${P}.patch )