summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/epubcheck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/epubcheck')
-rw-r--r--app-text/epubcheck/Manifest1
-rw-r--r--app-text/epubcheck/epubcheck-1.1.ebuild55
-rw-r--r--app-text/epubcheck/metadata.xml7
3 files changed, 63 insertions, 0 deletions
diff --git a/app-text/epubcheck/Manifest b/app-text/epubcheck/Manifest
new file mode 100644
index 000000000000..39f814b071cb
--- /dev/null
+++ b/app-text/epubcheck/Manifest
@@ -0,0 +1 @@
+DIST epubcheck-src-1.1.zip 2442421 SHA256 f9db760358b34d9d98d243156e38f905e0f8735d26b8bf3550e3b108f2436be9 SHA512 4ba5fbb149a071c1dfed97ab00500afabb0690eb081967203e8ae6691b3ab9d676bf0a4cb29c5cf203db253a8e7a4c1bfccbd07b2ee377ec02656ba378a6d252 WHIRLPOOL 4e98ab1b4c2ef3412bc0109876d84ad4b9a212b7718d8ea60214ca8521571b6c068ca6bbb62e371e2558e199ebe8003b517413881e0a59574ab14e2e5452baee
diff --git a/app-text/epubcheck/epubcheck-1.1.ebuild b/app-text/epubcheck/epubcheck-1.1.ebuild
new file mode 100644
index 000000000000..e88bab0331e3
--- /dev/null
+++ b/app-text/epubcheck/epubcheck-1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Tool to validate IDPF EPUB files"
+HOMEPAGE="https://code.google.com/p/epubcheck/"
+SRC_URI="https://${PN}.googlecode.com/files/${PN}-src-${PV}.zip"
+
+LICENSE="MIT BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEP="dev-java/jigsaw:0
+ dev-java/saxon:6.5"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ rm -f lib/*.jar
+
+ java-pkg_jar-from --into lib/ jigsaw
+ java-pkg_jar-from --into lib/ saxon-6.5
+
+ cd lib/
+ ln -s $(java-config --tools)
+}
+
+src_compile() {
+ eant buildJar
+}
+
+src_test() {
+ java -cp "$(java-pkg_getjars jigsaw,saxon-6.5):dist/${P}.jar" \
+ com.adobe.epubcheck.autotest.AutoTest testdocs/general/tests.xml testdocs/general/ \
+ || die "tests failed"
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+
+ java-pkg_dolauncher ${PN} --main com.adobe.epubcheck.tool.Checker
+
+ dodoc README.txt
+}
diff --git a/app-text/epubcheck/metadata.xml b/app-text/epubcheck/metadata.xml
new file mode 100644
index 000000000000..63ac5653603a
--- /dev/null
+++ b/app-text/epubcheck/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>