summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/krop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/krop')
-rw-r--r--app-text/krop/Manifest2
-rw-r--r--app-text/krop/krop-0.4.7.ebuild26
-rw-r--r--app-text/krop/krop-0.4.8.ebuild26
-rw-r--r--app-text/krop/metadata.xml8
4 files changed, 62 insertions, 0 deletions
diff --git a/app-text/krop/Manifest b/app-text/krop/Manifest
new file mode 100644
index 000000000000..78bccdf84096
--- /dev/null
+++ b/app-text/krop/Manifest
@@ -0,0 +1,2 @@
+DIST krop-0.4.7.tar.gz 34559 SHA256 fd44f83437ef6a1cb2933ab94e78385f9d7dd7b271d24549eadea700d93b84af SHA512 b38973b2084d1ac05d71e842137793d3569a1d46668e506e8a58eac4f7bd366db177d9f8af8243ed13cfe6f73885e0998ad91a1ded4c02f6d0d0102809476d10 WHIRLPOOL ecdf833981b922de9acee9ddc1467cfc056b91766ef8f4dcfc4b98b5b63fb55924f9df3d6aa3ac99a82ef86f2f8ef608ce7b2d62c52930d059a53b0121932d52
+DIST krop-0.4.8.tar.gz 34948 SHA256 71668fe54820ad11dc47f8caddc56e0d2553975e768bd724f26fa5f5389b0aab SHA512 440a3dff6c13eb83dc9ccbbcf672a297d66d66fbf9508e3c6ceda3b043868102afb1df3401fcf06adbea1baea92444ad0dfa2fd8e74b2d993c9fe4903c9327a1 WHIRLPOOL 65aa1d73dca26d3522d1bdf75501f25340487529057bdbbaeb90472d0d518e6e54a31e2b9f1f08c6037636cd83c4ef128444c519cafae3346c8e80489d7564dd
diff --git a/app-text/krop/krop-0.4.7.ebuild b/app-text/krop/krop-0.4.7.ebuild
new file mode 100644
index 000000000000..2650de6b624f
--- /dev/null
+++ b/app-text/krop/krop-0.4.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/pyPdf[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
diff --git a/app-text/krop/krop-0.4.8.ebuild b/app-text/krop/krop-0.4.8.ebuild
new file mode 100644
index 000000000000..fab8217f99b8
--- /dev/null
+++ b/app-text/krop/krop-0.4.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/pyPdf[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
diff --git a/app-text/krop/metadata.xml b/app-text/krop/metadata.xml
new file mode 100644
index 000000000000..bdb617ccf698
--- /dev/null
+++ b/app-text/krop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>printing</herd>
+<maintainer>
+ <email>dilfridge@gentoo.org</email>
+</maintainer>
+</pkgmetadata>