summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 08:58:36 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:44 +0100
commit1e3cbc2e503cda3dd5907bff9987a51305700efe (patch)
treed1346fde455f02ebf3e1f9a1260b2cb4ba3dfead /app-text/llpp/files
parentapp-misc/wcd: respect PKG_CONFIG and depend on pkgconfig (diff)
downloadgentoo-1e3cbc2e503cda3dd5907bff9987a51305700efe.tar.gz
gentoo-1e3cbc2e503cda3dd5907bff9987a51305700efe.tar.bz2
gentoo-1e3cbc2e503cda3dd5907bff9987a51305700efe.zip
app-text/llpp: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/llpp/files')
-rw-r--r--app-text/llpp/files/Makefile4
-rw-r--r--app-text/llpp/files/llpp-33-makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-text/llpp/files/Makefile b/app-text/llpp/files/Makefile
index 0bd94cab00f2..66a3fe4c4fd8 100644
--- a/app-text/llpp/files/Makefile
+++ b/app-text/llpp/files/Makefile
@@ -10,8 +10,8 @@ LIBDIR ?= /usr/lib
# includes and libs
PKGCONF_DEPS := freetype2 harfbuzz libopenjp2 libjpeg mupdf x11 zlib
CPPFLAGS += -D_GNU_SOURCE -DFFP
-CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wshadow $(shell pkg-config --cflags $(PKGCONF_DEPS))
-LDLIBS = -L$(LIBDIR) -lpthread -ljbig2dec $(shell pkg-config --libs $(PKGCONF_DEPS))
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wshadow $(shell ${PKG_CONFIG} --cflags $(PKGCONF_DEPS))
+LDLIBS = -L$(LIBDIR) -lpthread -ljbig2dec $(shell ${PKG_CONFIG} --libs $(PKGCONF_DEPS))
# ocaml
CAMLOPT = ocamlopt
diff --git a/app-text/llpp/files/llpp-33-makefile b/app-text/llpp/files/llpp-33-makefile
index 3a5c3122e251..6e4eabf8bf5c 100644
--- a/app-text/llpp/files/llpp-33-makefile
+++ b/app-text/llpp/files/llpp-33-makefile
@@ -10,8 +10,8 @@ LIBDIR ?= /usr/lib
# includes and libs
PKGCONF_DEPS := freetype2 harfbuzz libopenjp2 libjpeg mupdf x11 zlib
CPPFLAGS += -D_GNU_SOURCE -DFFP
-CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wshadow $(shell pkg-config --cflags $(PKGCONF_DEPS))
-LDLIBS = -L$(LIBDIR) -lpthread -ljbig2dec $(shell pkg-config --libs $(PKGCONF_DEPS))
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wshadow $(shell ${PKG_CONFIG} --cflags $(PKGCONF_DEPS))
+LDLIBS = -L$(LIBDIR) -lpthread -ljbig2dec $(shell ${PKG_CONFIG} --libs $(PKGCONF_DEPS))
# ocaml
CAMLOPT = ocamlopt