summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/lout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/lout')
-rw-r--r--app-text/lout/Manifest2
-rw-r--r--app-text/lout/files/lout-3.38-makefile.patch33
-rw-r--r--app-text/lout/lout-3.38-r1.ebuild86
-rw-r--r--app-text/lout/lout-3.39.ebuild86
-rw-r--r--app-text/lout/metadata.xml10
5 files changed, 217 insertions, 0 deletions
diff --git a/app-text/lout/Manifest b/app-text/lout/Manifest
new file mode 100644
index 000000000000..b45b4b9f26c7
--- /dev/null
+++ b/app-text/lout/Manifest
@@ -0,0 +1,2 @@
+DIST lout-3.38.tar.gz 2147395 SHA256 6a2adc64a8b4a81ed39893328778da284a6ab0da3e5e20f678425f2d53dad80a SHA512 ad396dc885e904e26c31498123f4e6e5dd1356da7fe623b2a812e9ae8442ee4c68ed3925854f8116687f46c9cc0084b6d39a3130d8b9d8a3ee0ee25d5b9b1f5e WHIRLPOOL 59c8d99710fbc5096f84e75be13a1e64213e0c783c0bff30594ff0d23148aab3a619f6c2064bd62f059a7593d92b34f4689266d80eeb42d559fcd468d37412d5
+DIST lout-3.39.tar.gz 2157040 SHA256 78a75504fa25c2e55539ecd9f4ba13ff1e402a1ffb307d70474a4d6033f6f389 SHA512 c4201976282f29f5cc57076ae314b6fa2e9aca3ab0512e50a3c6a67851a507a9c055a059ce7737318969836d19e8637a2bc0ed88f536892cbbeeb3b476234799 WHIRLPOOL 33011a2b193446b17cf8c56525159b4650d01259dbb5931e8635ebfb412e6379c3c2f3a6f1da2ad72d24c5a4a6130046b45154396313e042a85a9dbc03b2bc8d
diff --git a/app-text/lout/files/lout-3.38-makefile.patch b/app-text/lout/files/lout-3.38-makefile.patch
new file mode 100644
index 000000000000..cb7fc66bf432
--- /dev/null
+++ b/app-text/lout/files/lout-3.38-makefile.patch
@@ -0,0 +1,33 @@
+--- lout-3.38/makefile.orig 2008-10-13 23:35:17.000000000 +0200
++++ lout-3.38/makefile 2009-09-04 16:40:00.000000000 +0200
+@@ -295,11 +295,9 @@
+ ZLIB =
+ ZLIBPATH =
+
+-CC = gcc
+-
+ RCOPY = cp -r
+
+-COPTS = -ansi -pedantic -Wall -O3
++COPTS += -ansi -pedantic -Wall
+
+ CFLAGS = -DOS_UNIX=$(OSUNIX) \
+ -DOS_DOS=$(OSDOS) \
+@@ -333,7 +331,7 @@
+ z49.o z50.o z51.o z52.o
+
+ lout: $(OBJS)
+- $(CC) -o lout $(OBJS) $(ZLIB) -lm
++ $(CC) $(COPTS) $(LDFLAGS) -o lout $(OBJS) $(ZLIB) -lm
+ chmod a+x lout
+
+ $(OBJS): externs.h
+@@ -341,7 +339,7 @@
+ externs.h:
+
+ prg2lout: prg2lout.c
+- $(CC) $(COPTS) -o prg2lout prg2lout.c
++ $(CC) $(COPTS) $(LDFLAGS) -o prg2lout prg2lout.c
+ chmod a+x prg2lout
+
+ all: lout prg2lout
diff --git a/app-text/lout/lout-3.38-r1.ebuild b/app-text/lout/lout-3.38-r1.ebuild
new file mode 100644
index 000000000000..dc5d98481395
--- /dev/null
+++ b/app-text/lout/lout-3.38-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+IUSE="zlib doc"
+
+DESCRIPTION="high-level language for document formatting"
+HOMEPAGE="http://lout.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lout/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ local myconf
+ use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=-lz"
+ emake COPTS="${CFLAGS}" BINDIR="${EPREFIX}"/usr/bin \
+ LOUTLIBDIR="${EPREFIX}"/usr/share/lout \
+ LOUTDOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ MANDIR="${EPREFIX}"/usr/share/man/man1 \
+ ${myconf} lout prg2lout || die "emake prg2lout lout failed"
+}
+
+compile_doc() {
+ #
+ # SYNOPSIS: compile_doc file times
+ #
+
+ einfo "${1}:"
+ # yes, it *is* necessary to run this 6 times...
+ for i in $(seq 1 $(expr $2 - 1)) ; do
+ einfo " pass $i"
+ lout all -o ${docdir}/$1 -e /dev/null
+ done
+ # in the last one, let errors be reported
+ einfo " final pass"
+ lout all -o ${docdir}/$1 || die "final pass failed"
+}
+
+src_install() {
+ local bindir libdir docdir mandir
+ bindir=${ED}usr/bin
+ libdir=${ED}usr/share/lout
+ docdir=${ED}usr/share/doc/${PF}
+ mandir=${ED}usr/share/man/man1
+ export LOUTLIB=${libdir}
+ export PATH="${bindir}:${PATH}"
+
+ mkdir -p ${bindir} ${docdir} ${mandir}
+
+ make BINDIR=${bindir} \
+ LOUTLIBDIR=${libdir} \
+ LOUTDOCDIR=${docdir} \
+ MANDIR=${mandir} \
+ install installdoc installman || die "make install failed"
+
+ lout -x -s "${ED}"usr/share/lout/include/init || die "lout init failed"
+
+ mv ${docdir}/README{,.docs}
+ dodoc README READMEPDF blurb blurb.short whatsnew
+
+ if use doc ; then
+ einfo "building postscript documentation (may take a while)"
+ cd doc/user
+ compile_doc user.ps 6
+ cd ../design
+ compile_doc design.ps 3
+ cd ../expert
+ compile_doc expert.ps 4
+ cd ../slides
+ compile_doc slides.ps 2
+ fi
+}
diff --git a/app-text/lout/lout-3.39.ebuild b/app-text/lout/lout-3.39.ebuild
new file mode 100644
index 000000000000..105d711763ae
--- /dev/null
+++ b/app-text/lout/lout-3.39.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+IUSE="zlib doc"
+
+DESCRIPTION="high-level language for document formatting"
+HOMEPAGE="http://lout.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lout/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.38-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ local myconf
+ use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=-lz"
+ emake COPTS="${CFLAGS}" BINDIR="${EPREFIX}"/usr/bin \
+ LOUTLIBDIR="${EPREFIX}"/usr/share/lout \
+ LOUTDOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ MANDIR="${EPREFIX}"/usr/share/man/man1 \
+ ${myconf} lout prg2lout || die "emake prg2lout lout failed"
+}
+
+compile_doc() {
+ #
+ # SYNOPSIS: compile_doc file times
+ #
+
+ einfo "${1}:"
+ # yes, it *is* necessary to run this 6 times...
+ for i in $(seq 1 $(expr $2 - 1)) ; do
+ einfo " pass $i"
+ lout all -o ${docdir}/$1 -e /dev/null
+ done
+ # in the last one, let errors be reported
+ einfo " final pass"
+ lout all -o ${docdir}/$1 || die "final pass failed"
+}
+
+src_install() {
+ local bindir libdir docdir mandir
+ bindir=${ED}usr/bin
+ libdir=${ED}usr/share/lout
+ docdir=${ED}usr/share/doc/${PF}
+ mandir=${ED}usr/share/man/man1
+ export LOUTLIB=${libdir}
+ export PATH="${bindir}:${PATH}"
+
+ mkdir -p ${bindir} ${docdir} ${mandir}
+
+ make BINDIR=${bindir} \
+ LOUTLIBDIR=${libdir} \
+ LOUTDOCDIR=${docdir} \
+ MANDIR=${mandir} \
+ install installdoc installman || die "make install failed"
+
+ lout -x -s "${ED}"usr/share/lout/include/init || die "lout init failed"
+
+ mv ${docdir}/README{,.docs}
+ dodoc README READMEPDF blurb blurb.short whatsnew
+
+ if use doc ; then
+ einfo "building postscript documentation (may take a while)"
+ cd doc/user
+ compile_doc user.ps 6
+ cd ../design
+ compile_doc design.ps 3
+ cd ../expert
+ compile_doc expert.ps 4
+ cd ../slides
+ compile_doc slides.ps 2
+ fi
+}
diff --git a/app-text/lout/metadata.xml b/app-text/lout/metadata.xml
new file mode 100644
index 000000000000..ae08f33fba24
--- /dev/null
+++ b/app-text/lout/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">lout</remote-id>
+ </upstream>
+</pkgmetadata>