summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-09-24 16:00:14 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-09-24 16:00:14 -0700
commit4ce33176e39e722fa79515ec4832374d8eab0bff (patch)
tree33fcb596555cdd14616279af6918a63624850361 /app-text/lowdown
parentapp-containers/containerd: Fix removal of the gen-manpages binary (diff)
downloadgentoo-4ce33176e39e722fa79515ec4832374d8eab0bff.tar.gz
gentoo-4ce33176e39e722fa79515ec4832374d8eab0bff.tar.bz2
gentoo-4ce33176e39e722fa79515ec4832374d8eab0bff.zip
app-text/lowdown: add 1.1.1
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-text/lowdown')
-rw-r--r--app-text/lowdown/Manifest1
-rw-r--r--app-text/lowdown/lowdown-1.1.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-text/lowdown/Manifest b/app-text/lowdown/Manifest
index c01019b38596..ab6da42a7555 100644
--- a/app-text/lowdown/Manifest
+++ b/app-text/lowdown/Manifest
@@ -1 +1,2 @@
DIST lowdown-1.1.0.tar.gz 599219 BLAKE2B f623399cb41c5eaf180550283c5b2738993563ff30be4cfa1a471df036ed4289057d3f886a7727d85283896fbfe1316e9cc86d32c629cea1fd775af16cf58839 SHA512 b7b788694abf6760ca4abbd8d5d2c226d5406067ebf9b55307f136e1ab373e517fb20187659c09029463872310a5b39a0129842d1bc6b7bd64f2d440390e2676
+DIST lowdown-1.1.1.tar.gz 600635 BLAKE2B 39c0a2472ff6b9b3fa2b6d72c1f2d482592976f7b50c1bbaf1965bfbb6d28f22e0a7498bb54087bb83070bd74ea673409be97815f51a0a5a67e980bbfc4e01b2 SHA512 2a69da945a83696480651e8221d73bcb18bac9bc38bb88126ddf73520d2a4ff396dde08a7abf6f550669ec9ba34abdaa186b0980f312fa157371ee754576bb6a
diff --git a/app-text/lowdown/lowdown-1.1.1.ebuild b/app-text/lowdown/lowdown-1.1.1.ebuild
new file mode 100644
index 000000000000..a008b37b88a4
--- /dev/null
+++ b/app-text/lowdown/lowdown-1.1.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PV="VERSION_${PV//./_}"
+DESCRIPTION="Markdown translator producing HTML5, roff documents in the ms and man formats"
+HOMEPAGE="https://kristaps.bsd.lv/lowdown/"
+SRC_URI="https://github.com/kristapsdz/lowdown/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="ISC"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ virtual/libcrypt:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+# configure tests for a bunch of BSD functions on Linux
+QA_CONFIG_IMPL_DECL_SKIP=(
+ crypt_newhash
+ crypt_checkpass
+ warnc
+ errc
+ getexecname
+ getprogname
+ memset_s
+ pledge
+ recallocarray
+ strlcat
+ strlcpy
+ strtonum
+ TAILQ_FOREACH_SAFE
+ unveil
+)
+
+PATCHES=(
+ "${FILESDIR}/lowdown-0.10.0-pkgconfig-libmd.patch"
+ "${FILESDIR}/lowdown-1.1.0-shared-linking.patch"
+)
+
+src_configure() {
+ append-flags -fPIC
+ tc-export CC AR
+
+ ./configure \
+ PREFIX="/usr" \
+ MANDIR="/usr/share/man" \
+ LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LIBDIR="/usr/$(get_libdir)" \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" emake regress
+}