summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-06-22 11:39:00 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-06-22 11:47:56 +0200
commit5a78cc2d0f36d6c81e730a62cde3a8784be2a49e (patch)
tree78eb4788060d6253ce8b0d90896eae06138c8367 /app-text/pdfjam
parentapp-text/texlive-core: drop epspdf and pdfjam blockers (diff)
downloadgentoo-5a78cc2d0f36d6c81e730a62cde3a8784be2a49e.tar.gz
gentoo-5a78cc2d0f36d6c81e730a62cde3a8784be2a49e.tar.bz2
gentoo-5a78cc2d0f36d6c81e730a62cde3a8784be2a49e.zip
app-text/pdfjam: add 3.10
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/pdfjam')
-rw-r--r--app-text/pdfjam/Manifest1
-rw-r--r--app-text/pdfjam/pdfjam-3.10.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/pdfjam/Manifest b/app-text/pdfjam/Manifest
index 2387996159b3..b1ba891c3266 100644
--- a/app-text/pdfjam/Manifest
+++ b/app-text/pdfjam/Manifest
@@ -1 +1,2 @@
+DIST pdfjam-3.10.tar.gz 121928 BLAKE2B 5ff82abba43becb2792ff9e6a13dd3458d4b884e9e2361d116c638bb8a396fd8ca833361dfbc981433ebf445cfa8bfe99bb5fc7f1a76a35361666b91acef934e SHA512 dd69d8e5f86bb4fcb8db0e71454fdb0f2dd75e222d68e8cf3870d9f318aa7e8ccf51f87977ad71ddba1d78569e358044b111b8014f88dddf86654dc5bc334e90
DIST pdfjam_208.tgz 180725 BLAKE2B 903ce4f0874c9fc9ad23f3db37b882596589d6470dfe9289f65a72fb66ff843bbd49b52086d7b2d2cbbfb1b6406cbbda64d46b933a853d5d681ef88d4033372c SHA512 728c8d304c6d2af773980d20ef4a4be6e0a5dad286ad8cd00be9b1687f5024e00032a750c10c74dcd24431f081368d02b76f03cc5bb1c8725a060cd70be0fd8c
diff --git a/app-text/pdfjam/pdfjam-3.10.ebuild b/app-text/pdfjam/pdfjam-3.10.ebuild
new file mode 100644
index 000000000000..fefcf36b724e
--- /dev/null
+++ b/app-text/pdfjam/pdfjam-3.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Allows the manipulation of PDF files (pdfnup, pdfjoin and pdf90)"
+HOMEPAGE="https://github.com/rrthomas/pdfjam"
+SRC_URI="https://github.com/rrthomas/pdfjam/releases/download/v${PV}/pdfjam-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="virtual/latex-base"
+RDEPEND="
+ ${DEPEND}
+ !<dev-texlive/texlive-binextra-2023_p69527-r4
+"
+BDEPEND="test? ( app-arch/unzip )"
+
+src_prepare() {
+ default
+ if use test; then
+ unzip tests.zip || die
+ fi
+}
+
+src_test() {
+ ./tests/run.sh || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README.md
+ doman man1/*
+
+ insinto usr/share/etc
+ doins pdfjam.conf
+}