summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-22 02:59:52 +0100
committerSam James <sam@gentoo.org>2022-09-22 03:00:02 +0100
commit906a05471224deda1e50c7e60caa3b5d632650df (patch)
tree8f1a6add46c5ed685a3ec65ca5ca9638cf622aef /app-text/recode
parentmedia-sound/deadbeef: Add USE=libsamplerate (diff)
downloadgentoo-906a05471224deda1e50c7e60caa3b5d632650df.tar.gz
gentoo-906a05471224deda1e50c7e60caa3b5d632650df.tar.bz2
gentoo-906a05471224deda1e50c7e60caa3b5d632650df.zip
app-text/recode: call python-any-r1_pkg_setup conditionally
For example, in the middle of Python target migrations, we may not have a working "Python" for the purposes of the eclass. It's only in BDEPEND="test? ( ... )" so we shouldn't be checking for it, as the dep isn't enforcing it unconditionally. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/recode-3.7.12.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-text/recode/recode-3.7.12.ebuild b/app-text/recode/recode-3.7.12.ebuild
index 7f4e75b9cc71..260cc59d1dbd 100644
--- a/app-text/recode/recode-3.7.12.ebuild
+++ b/app-text/recode/recode-3.7.12.ebuild
@@ -34,9 +34,11 @@ BDEPEND="
"
python_check_deps() {
- if use test ; then
- has_version -b "dev-python/cython[${PYTHON_USEDEP}]" || return 1
- fi
+ has_version -b "dev-python/cython[${PYTHON_USEDEP}]" || return 1
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
}
src_configure() {