summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/rtf2html
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/rtf2html')
-rw-r--r--app-text/rtf2html/Manifest1
-rw-r--r--app-text/rtf2html/files/rtf2html-0.2.0-gcc43.patch22
-rw-r--r--app-text/rtf2html/metadata.xml11
-rw-r--r--app-text/rtf2html/rtf2html-0.2.0-r1.ebuild35
4 files changed, 69 insertions, 0 deletions
diff --git a/app-text/rtf2html/Manifest b/app-text/rtf2html/Manifest
new file mode 100644
index 000000000000..4de1fd00e18f
--- /dev/null
+++ b/app-text/rtf2html/Manifest
@@ -0,0 +1 @@
+DIST rtf2html-0.2.0.tar.bz2 75292 SHA256 13d39bdd3387aeba1e640d3209aa2ce56871291247734757d399675e4b8b918b SHA512 7399c98adb4dc0f45e420cd6836c36720d6b19ccbba062d2102b2693a6812642d6193000172ef7eeef5b8a84dcb2d35c1eb99fbf3bffaf8dad43e8ca06c6fe75 WHIRLPOOL 077eb9d7fec11796e4a1c4257bd6380621a3c112bb9faab0e1090a8419b96c49e2bf7fced42bd5568408fa497d691f61a99eb538c35c1409d9ee703d7654397d
diff --git a/app-text/rtf2html/files/rtf2html-0.2.0-gcc43.patch b/app-text/rtf2html/files/rtf2html-0.2.0-gcc43.patch
new file mode 100644
index 000000000000..f87661fd3796
--- /dev/null
+++ b/app-text/rtf2html/files/rtf2html-0.2.0-gcc43.patch
@@ -0,0 +1,22 @@
+diff -ur rtf2html-0.2.0-orig/rtf_keyword.h rtf2html-0.2.0/rtf_keyword.h
+--- rtf2html-0.2.0-orig/rtf_keyword.h 2007-08-03 04:50:45.000000000 -0400
++++ rtf2html-0.2.0/rtf_keyword.h 2009-01-03 17:45:14.000000000 -0500
+@@ -2,6 +2,7 @@
+
+ #include "config.h"
+ #include <string>
++#include <cstdlib>
+ #include <map>
+ #include <ctype.h>
+
+diff -ur rtf2html-0.2.0-orig/rtf_table.cpp rtf2html-0.2.0/rtf_table.cpp
+--- rtf2html-0.2.0-orig/rtf_table.cpp 2007-07-31 11:16:52.000000000 -0400
++++ rtf2html-0.2.0/rtf_table.cpp 2009-01-03 17:45:14.000000000 -0500
+@@ -4,6 +4,7 @@
+ #include <iostream>
+ #include <stdexcept>
+ #include <functional>
++#include <algorithm>
+
+ typedef std::set<int> intset;
+
diff --git a/app-text/rtf2html/metadata.xml b/app-text/rtf2html/metadata.xml
new file mode 100644
index 000000000000..fdb7d4cec9d9
--- /dev/null
+++ b/app-text/rtf2html/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">rtf2html</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..3199bdae8125
--- /dev/null
+++ b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base flag-o-matic
+
+DESCRIPTION="RTF to HTML converter"
+HOMEPAGE="http://rtf2html.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rtf2html/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README )
+
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
+src_prepare() {
+ # CFLAGS are incorrectly parsed, so handle this here
+ sed -i -e '/CFLAGS=$(echo $CFLAGS/d' configure || die 'sed on configure failed'
+ use !debug && filter-flags "-g*"
+
+ base_src_prepare
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}