summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-14 12:04:28 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-14 12:08:51 +0200
commit8e1c3c9177201436f99353384bfd73c66d79299e (patch)
tree51c43b7b3fdb591ebe40097cbeda751fd8c8f03d /app-text/sablotron/sablotron-1.0.3-r2.ebuild
parentapp-text/glosung: Remove last-rited package (diff)
downloadgentoo-8e1c3c9177201436f99353384bfd73c66d79299e.tar.gz
gentoo-8e1c3c9177201436f99353384bfd73c66d79299e.tar.bz2
gentoo-8e1c3c9177201436f99353384bfd73c66d79299e.zip
app-text/sablotron: Format sabcmd.cpp for C++11 compatibility
While there: - Add IUSE=static-libs and remove .la files - Clean up patch - EAPI=7 - Replace defunct HOMEPAGE/SRC_URI Package-Manager: Portage-3.0.2, Repoman-2.3.23 Closes: https://bugs.gentoo.org/show_bug.cgi?id=726732 Closes: https://bugs.gentoo.org/show_bug.cgi?id=729590 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-text/sablotron/sablotron-1.0.3-r2.ebuild')
-rw-r--r--app-text/sablotron/sablotron-1.0.3-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-text/sablotron/sablotron-1.0.3-r2.ebuild b/app-text/sablotron/sablotron-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..3d8288a19d60
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.3-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_PN="Sablot"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="https://sourceforge.net/projects/sablotron/"
+SRC_URI="mirror://sourceforge/sablotron/${MY_P}.tar.gz"
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl static-libs"
+
+RDEPEND="
+ >=dev-libs/expat-1.95.6-r1
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ >=dev-perl/XML-Parser-2.3
+"
+DOCS=(
+ README README_JS RELEASE src/TODO
+)
+PATCHES=(
+ "${FILESDIR}"/1.0.3-libsablot-expat.patch
+ "${FILESDIR}"/1.0.3-cxx11.patch
+)
+
+src_prepare() {
+ default
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable perl perlconnect) \
+ $(use_enable static-libs static) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}