summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/sigil
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/sigil')
-rw-r--r--app-text/sigil/Manifest2
-rw-r--r--app-text/sigil/metadata.xml15
-rw-r--r--app-text/sigil/sigil-0.8.5.ebuild55
-rw-r--r--app-text/sigil/sigil-0.8.6.ebuild55
4 files changed, 127 insertions, 0 deletions
diff --git a/app-text/sigil/Manifest b/app-text/sigil/Manifest
new file mode 100644
index 000000000000..556133edd9fc
--- /dev/null
+++ b/app-text/sigil/Manifest
@@ -0,0 +1,2 @@
+DIST sigil-0.8.5.tar.gz 19394323 SHA256 12540493685988a2a3a3898675b8c92c422fbec43513bdd935b802fc68ca40f4 SHA512 fd4d65afe5afe97522727681963c08483b9ab78070fed2e13c987a45d5f8b9885d7a55c721d25213c097016bd1c375369f1ebedc079329bd995955e6d75d2d06 WHIRLPOOL 0026e04e9f304186a5f6c6d7756cdb30c004e0da4f969d89c19dfa1a475dfe29a85058c82d4066089111778d83c411d520bced0ce19e8fd94b80f0a1a5608ad6
+DIST sigil-0.8.6.tar.gz 19394568 SHA256 5f89b47abbf0a7befa4e776083db5426456f8ef1ef50bd168dc98d621fb2ad26 SHA512 5d45ca43520f6fd13e83c97da24d613a05e9b33dd0e07637f872a0fb6050f345f9228a8f63d1e81ee727f07d6dbdf306d55fdb51d0ac67dde33327465c3c6732 WHIRLPOOL 99388aef513842b930c4f549fdfa23414366a9af390850fa982dd3ef53d59ab4bd443001929bb50d83699ed4f960104f8f96452744a9acb5f08416843dcbe960
diff --git a/app-text/sigil/metadata.xml b/app-text/sigil/metadata.xml
new file mode 100644
index 000000000000..384cf8e3576d
--- /dev/null
+++ b/app-text/sigil/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>tomboy64@sina.cn</email>
+ <description>Maintainer, assign bugs to him</description>
+ </maintainer>
+ <longdescription lang="en">Sigil is a multi-platform WYSIWYG ebook editor.
+ It is designed to edit books in ePub format.</longdescription>
+ <upstream>
+ <remote-id type="google-code">sigil</remote-id>
+ <remote-id type="github">user-none/Sigil</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/sigil/sigil-0.8.5.ebuild b/app-text/sigil/sigil-0.8.5.ebuild
new file mode 100644
index 000000000000..f830538b4738
--- /dev/null
+++ b/app-text/sigil/sigil-0.8.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CMAKE_MIN_VERSION="3.0"
+CMAKE_BUILD_TYPE="Release"
+
+# This ebuild could use some python checks, as sigil contains python plugin architecture.
+
+inherit eutils cmake-utils
+
+MY_PN="Sigil"
+
+DESCRIPTION="Sigil is a multi-platform WYSIWYG ebook editor for ePub format"
+HOMEPAGE="http://sigil-ebook.com/"
+SRC_URI="https://github.com/user-none/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sys-libs/zlib-1.2.7[minizip]
+ >=dev-libs/libpcre-8.31[pcre16]
+ >=dev-libs/boost-1.49[threads]
+ >=app-text/hunspell-1.3.2
+ >=dev-libs/xerces-c-3.1.1[icu]
+ >=dev-qt/qtcore-5.4:5
+ >=dev-qt/qtwebkit-5.4:5
+ >=dev-qt/qtsvg-5.4:5
+ >=dev-qt/qtgui-5.4:5
+ >=dev-qt/qtwidgets-5.4:5
+ >=dev-qt/qtxml-5.4:5
+ >=dev-qt/qtxmlpatterns-5.4:5
+ >=dev-qt/qtconcurrent-5.4:5
+ >=dev-qt/qtprintsupport-5.4:5
+ >=dev-qt/qtnetwork-5.4:5
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-qt/linguist-tools-5.4:5
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( README.md )
+
+src_prepare() {
+ # sigil tries to copy non-needed qt libs for deb package, safe to ignore this completely
+ sed -e '/set( QT_LIBS/d' -i src/Sigil/CMakeLists.txt || die 'sed failed'
+
+ cmake-utils_src_prepare
+}
diff --git a/app-text/sigil/sigil-0.8.6.ebuild b/app-text/sigil/sigil-0.8.6.ebuild
new file mode 100644
index 000000000000..f830538b4738
--- /dev/null
+++ b/app-text/sigil/sigil-0.8.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CMAKE_MIN_VERSION="3.0"
+CMAKE_BUILD_TYPE="Release"
+
+# This ebuild could use some python checks, as sigil contains python plugin architecture.
+
+inherit eutils cmake-utils
+
+MY_PN="Sigil"
+
+DESCRIPTION="Sigil is a multi-platform WYSIWYG ebook editor for ePub format"
+HOMEPAGE="http://sigil-ebook.com/"
+SRC_URI="https://github.com/user-none/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sys-libs/zlib-1.2.7[minizip]
+ >=dev-libs/libpcre-8.31[pcre16]
+ >=dev-libs/boost-1.49[threads]
+ >=app-text/hunspell-1.3.2
+ >=dev-libs/xerces-c-3.1.1[icu]
+ >=dev-qt/qtcore-5.4:5
+ >=dev-qt/qtwebkit-5.4:5
+ >=dev-qt/qtsvg-5.4:5
+ >=dev-qt/qtgui-5.4:5
+ >=dev-qt/qtwidgets-5.4:5
+ >=dev-qt/qtxml-5.4:5
+ >=dev-qt/qtxmlpatterns-5.4:5
+ >=dev-qt/qtconcurrent-5.4:5
+ >=dev-qt/qtprintsupport-5.4:5
+ >=dev-qt/qtnetwork-5.4:5
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-qt/linguist-tools-5.4:5
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( README.md )
+
+src_prepare() {
+ # sigil tries to copy non-needed qt libs for deb package, safe to ignore this completely
+ sed -e '/set( QT_LIBS/d' -i src/Sigil/CMakeLists.txt || die 'sed failed'
+
+ cmake-utils_src_prepare
+}