summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-15 12:17:18 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-15 12:30:50 -0700
commit0b94ac7a162de4040e8248e8b06807660abba751 (patch)
tree9159b9bf52ae4216cc01fa286a2af47d952b82a0 /app-text
parentapp-misc/gnote: Version bump to 40.2 (diff)
downloadgentoo-0b94ac7a162de4040e8248e8b06807660abba751.tar.gz
gentoo-0b94ac7a162de4040e8248e8b06807660abba751.tar.bz2
gentoo-0b94ac7a162de4040e8248e8b06807660abba751.zip
app-text/enchant: Version bump to 2.3.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-2.3.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index cb47cc00ddcf..2f2f49fe28e6 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1,2 +1,3 @@
DIST enchant-1.6.1.tar.gz 642124 BLAKE2B d41aa9b313e7fe8b0887728b55f3c5218e270c7359b4edcdc8d9180af68687230bcc9f7d1abb9f85ac673478530e5674366c9bc7d08b983e7226725b2cdd73d3 SHA512 26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036
DIST enchant-2.2.15.tar.gz 990693 BLAKE2B 09d380fc90cf8404345e88fb4e676f92e795b43e1caa5f21e52c6f3037268b1959e9cd1adf04b08e05fce78dbbcfd3163795e8d2079c484c530065566a0307f2 SHA512 e29b3a85d993af28044a86dd23a3ca74c7d50b4218e542c380053a3eaf70c3ea2406feb3361ba8e793bac586c252330bb20fb56c65f3a0a54f63f103cc0abb35
+DIST enchant-2.3.0.tar.gz 986837 BLAKE2B 57859d41d1e605ba5b89a264e3b6f53bab7a2f060c2b306a1ac51c55925d5b30a5d40fd121be7d3df22395cc11ad4808e63627f7e0f5ae9f3c1d2f2939dc2f68 SHA512 ed25d74176aefe4ab3b1754ea09356d04c844f8e7a50441d331fcf6a0fefbedaffa21df7296b7947ab1fcd44844c1d8567d39d67ebc4381ce8766577c0269d43
diff --git a/app-text/enchant/enchant-2.3.0.ebuild b/app-text/enchant/enchant-2.3.0.ebuild
new file mode 100644
index 000000000000..1c7845af2065
--- /dev/null
+++ b/app-text/enchant/enchant-2.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+IUSE="aspell +hunspell test voikko"
+REQUIRED_USE="|| ( hunspell aspell )"
+
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )
+ voikko? ( dev-libs/libvoikko )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/unittest++-2.0.0-r2 )"
+BDEPEND="virtual/pkgconfig"
+
+RESTRICT="test" # Tests fail
+
+src_configure() {
+ # TODO: Add app-text/nuspell support
+ econf \
+ --datadir="${EPREFIX}"/usr/share/enchant-2 \
+ --disable-static \
+ $(use_enable test relocatable) \
+ $(use_with aspell) \
+ $(use_with hunspell) \
+ $(use_with voikko) \
+ --without-nuspell \
+ --without-hspell \
+ --without-applespell \
+ --without-zemberek \
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}