summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-09-03 16:39:22 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-10-21 15:36:23 +0300
commit11eeb21388172aa2bfee0e21195ba834a062acbd (patch)
tree75474de7afed54d279fac2a605092b91d3cef9d8 /app-text
parentapp-text/zathura-pdf-poppler: update live (diff)
downloadgentoo-11eeb21388172aa2bfee0e21195ba834a062acbd.tar.gz
gentoo-11eeb21388172aa2bfee0e21195ba834a062acbd.tar.bz2
gentoo-11eeb21388172aa2bfee0e21195ba834a062acbd.zip
app-text/zathura-ps: add 0.2.8
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura-ps/Manifest1
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.8.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/zathura-ps/Manifest b/app-text/zathura-ps/Manifest
index 70c1e626dabc..12db566664a2 100644
--- a/app-text/zathura-ps/Manifest
+++ b/app-text/zathura-ps/Manifest
@@ -1 +1,2 @@
DIST zathura-ps-0.2.7.tar.xz 4488 BLAKE2B 4513173a2f9ca725abf8444516a78fd789286b082a1146ab5d0dee504cdda92962f3e6cef46f24e0307bc5ea6bb6595577fac2dfbd2d4ef0cf8e69d34337baf5 SHA512 86cf4cea8f32e446960c7727745711d6bb6723bb41127ccba335fbdaeb78e9f681ce4104b2be8718a2f19e06aef30d49ae7c90091fa0774b5ffe22303cf37d5f
+DIST zathura-ps-0.2.8.tar.xz 4716 BLAKE2B d9377a00fcc9e45fae413676947ff2067c80362bd9f9f1573f9962459d9a636ed0743decbe437bf90ab9e65dcdb8b5d0b19ad1794085c313fa473f0241a101bf SHA512 29ed9d5585df1151af50835daa75a11befbd0fe10e95b4a37c7b548e1442edd3f52a7d0afce8cca93ce70ced6381cdf23311cea004e3e38a6cb323ba13eb7039
diff --git a/app-text/zathura-ps/zathura-ps-0.2.8.ebuild b/app-text/zathura-ps/zathura-ps-0.2.8.ebuild
new file mode 100644
index 000000000000..e5fed454182c
--- /dev/null
+++ b/app-text/zathura-ps/zathura-ps-0.2.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://pwmt.org/projects/zathura-ps/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="PostScript plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura-ps/download/"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+# Tests currently only validating data files
+RESTRICT="test"
+
+DEPEND="app-text/libspectre
+ >=app-text/zathura-0.3.9
+ dev-libs/girara:=
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}