summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2017-04-10 13:12:44 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2017-04-10 13:12:44 +0200
commit413bad613bd86d73a6888687e338ec31beacecb1 (patch)
tree6cc1d883f9cf6457db5db6e2d45d09062f076ed5 /app-text
parentapp-text/docbook-dsssl-stylesheets: EAPI bump (diff)
downloadgentoo-413bad613bd86d73a6888687e338ec31beacecb1.tar.gz
gentoo-413bad613bd86d73a6888687e338ec31beacecb1.tar.bz2
gentoo-413bad613bd86d73a6888687e338ec31beacecb1.zip
app-text/psutils: EAPI bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-text')
-rw-r--r--app-text/psutils/psutils-1.17-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/psutils/psutils-1.17-r3.ebuild b/app-text/psutils/psutils-1.17-r3.ebuild
new file mode 100644
index 000000000000..24f0a285f2f8
--- /dev/null
+++ b/app-text/psutils/psutils-1.17-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="PostScript Utilities"
+HOMEPAGE="http://web.archive.org/web/20110722005140/http://www.tardis.ed.ac.uk/~ajcd/psutils/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.dfsg.orig.tar.gz"
+
+LICENSE="psutils"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${P}.orig"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-ldflags.patch"
+ eapply "${FILESDIR}/${P}-no-fixmacps.patch"
+ sed \
+ -e "s:/usr/local:\$(DESTDIR)${EPREFIX}/usr:" \
+ "${S}/Makefile.unix" > "${S}/Makefile"
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dodir /usr/{bin,share/man}
+ emake DESTDIR="${D}" install
+ dodoc README
+}