summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-07 11:11:23 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-07 11:11:57 -0400
commitaaedd2879bb0f33ca2f9698a10cf2f396932e8ec (patch)
treeebb9c257879b673c9ef94cf224b009615c559420 /app-text
parentwww-apps/baikal: cleanup (diff)
downloadgentoo-aaedd2879bb0f33ca2f9698a10cf2f396932e8ec.tar.gz
gentoo-aaedd2879bb0f33ca2f9698a10cf2f396932e8ec.tar.bz2
gentoo-aaedd2879bb0f33ca2f9698a10cf2f396932e8ec.zip
app-text/rarian: Version bump to 0.8.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rarian/Manifest1
-rw-r--r--app-text/rarian/rarian-0.8.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-text/rarian/Manifest b/app-text/rarian/Manifest
index a88868d963c4..0c3dd57d0e7b 100644
--- a/app-text/rarian/Manifest
+++ b/app-text/rarian/Manifest
@@ -1,3 +1,4 @@
DIST rarian-0.8.1-r4-patches.tar.xz 33868 BLAKE2B e272598fce4119ad4995b665b988080dc4aee23ba6d03e462e4c76186a418601cbc5c4f403beb64aad05c9e7003d58c2070122ddcaf7188335ec4b8370eb7afb SHA512 766223faedb743c350de4f5c4dc3081f95a2c617d52ddedd4e78f64b3cbbacc20293cc4e98bbe38b41f795cefbf83d624d4434c2b94129ce224ad66da9e5760c
DIST rarian-0.8.1.tar.gz 459461 BLAKE2B 7589633a3abc188a7e83adede964b4d293984ad9c896e5c8116775905dfc3acc3b0cfbbee574b26d1c3966501f8b42e61df9910c840c58bfcd0b41d065a30c26 SHA512 ddc640e1ac210e9dc3fcdde6bbff6e21dabe97b160b531cac68d47d1b831dec71b7c4aced9819cfafd8f89f290920c4e33550b8e29d9872a1c1a202d6fe8e3eb
DIST rarian-0.8.3.tar.bz2 405163 BLAKE2B 7d630a0e94cdcee9cb832296d25e8aa034e8c900532d16d2ed82c80009916db277f25d53264790321e4e7bf8570868a90392695f9b28e0c88852cb0611832c02 SHA512 3fa62e2e9051aaf1b2665954cc9217acd48d43ab43b8fb1a20165853bb5fc67e2508b23eb2c576ab29eaa7c254266a9e1fc8e8b22d2470cf3dbcabb528c41ad0
+DIST rarian-0.8.4.tar.bz2 402769 BLAKE2B bc077a6584f7ad0967cdaf298769d1da5ea4b9545191bcf7a8d4f07178666c416b8471a79447e6e3ff52bb2bfd8c55afc7d1638211d245abd9d4efe82c30a7a2 SHA512 5daf8c70438db566f8c4fc6a9b553898e078882307951e7060873fb4c32c12a6482f560f14dab9376917996a3a2f84a36bdf2721fa94c3e63379e3ea0ed131d4
diff --git a/app-text/rarian/rarian-0.8.4.ebuild b/app-text/rarian/rarian-0.8.4.ebuild
new file mode 100644
index 000000000000..cdff7810d072
--- /dev/null
+++ b/app-text/rarian/rarian-0.8.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A documentation metadata library"
+HOMEPAGE="https://rarian.freedesktop.org/"
+SRC_URI="https://gitlab.freedesktop.org/rarian/rarian/-/releases/${PV}/downloads/assets/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/libxslt
+ dev-libs/tinyxml
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-libs/check-0.9.6 )
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/util-linux
+"
+
+src_configure() {
+ local myconf=(
+ --localstatedir="${EPREFIX}"/var
+ $(use_with test check)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib/rarian
+ find "${ED}" -name '*.la' -delete || die
+}