summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-28 23:49:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-28 23:50:56 +0100
commitfd75a5a4634dccd9728140af100ed236f71c342e (patch)
treeae1e1af298c1138f8087473e4dc3a4a44a0f4fb2 /app-text
parentmedia-libs/libcdr: add 0.1.8 (diff)
downloadgentoo-fd75a5a4634dccd9728140af100ed236f71c342e.tar.gz
gentoo-fd75a5a4634dccd9728140af100ed236f71c342e.tar.bz2
gentoo-fd75a5a4634dccd9728140af100ed236f71c342e.zip
app-text/libetonyek: add 0.1.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libetonyek/Manifest1
-rw-r--r--app-text/libetonyek/libetonyek-0.1.12.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-text/libetonyek/Manifest b/app-text/libetonyek/Manifest
index 11dc0cfc143d..3edc2b7afc4a 100644
--- a/app-text/libetonyek/Manifest
+++ b/app-text/libetonyek/Manifest
@@ -1,2 +1,3 @@
DIST libetonyek-0.1.10.tar.xz 1494000 BLAKE2B 1c47b410050380d134d96b5551f0c9186c24aa0ea52c801e26655e3013f030e92198d8e3f19e8a341744206eeaad2d10ca130f286fd42c8a9c3b56f773cfa7d5 SHA512 516a14fcb7b7b5898484a4263d593a036ac728b90144da9d1c22a5d0fdffc879839e19a7b390f99d924c390d433e64433fb08939b1e04ca24359315571c5772b
DIST libetonyek-0.1.11.tar.xz 1513056 BLAKE2B 2c96e85b4c11ae33a858e3b3f6ec3c76aaa9b9a4e798f436ae5a379adc48622ca5f1da1d7a7b29b2dac8dab27c05acc2f98d778c5258432c688534fbcce0eb86 SHA512 b04593062d905340fdc6049d9fcd4524f8f8d8e313041b1ca811c63c08b218398b11a5cd6c3c724659d108c6f15756d5a87c88e85e27b2b5ed846af3b90de2ab
+DIST libetonyek-0.1.12.tar.xz 1513688 BLAKE2B d2333229d619019965f4837b3201f6f4caa4a284988a859ccbc1eab8624154135d2ca8e7b3aba5a332b2cb9b683de53ecf147d99ed09acb6c86e2a518fb60b77 SHA512 7b194a3ba8fc5b83b27e69c9cb7ac26df3830a1d2d2e114b01bfd63cf144f41d8c3c238e39e67bb96101fa2ed80e6b41a328a7cdd70628bdd3b9b732576b0980
diff --git a/app-text/libetonyek/libetonyek-0.1.12.ebuild b/app-text/libetonyek/libetonyek-0.1.12.ebuild
new file mode 100644
index 000000000000..535cecb7dd54
--- /dev/null
+++ b/app-text/libetonyek/libetonyek-0.1.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libetonyek/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library parsing Apple Keynote presentations"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-text/liblangtag
+ dev-libs/librevenge
+ dev-libs/libxml2
+ >=dev-util/mdds-2.1:1=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ media-libs/glm
+ dev-build/libtool
+ test? ( dev-util/cppunit )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4" || die
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ --with-mdds=2.1
+ $(use_with doc docs)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -type f -delete || die
+}