summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-11-06 00:34:45 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-06 00:35:57 +0100
commit3eb669ffb0a423507e71b746614dd5a40f1e545e (patch)
tree03cf2eeb9f6662179c4d8bbbe5c0849646c10cb4 /app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
parentdev-php/PEAR-PEAR: remove unused PEAR-PEAR-1.10.3-r2.ebuild. (diff)
downloadgentoo-3eb669ffb0a423507e71b746614dd5a40f1e545e.tar.gz
gentoo-3eb669ffb0a423507e71b746614dd5a40f1e545e.tar.bz2
gentoo-3eb669ffb0a423507e71b746614dd5a40f1e545e.zip
app-vim/vim2hs: new package.
vim2hs is a collection of vimscripts for Haskell development. Closes: https://bugs.gentoo.org/476450 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild')
-rw-r--r--app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
new file mode 100644
index 000000000000..4d8504e4b3a0
--- /dev/null
+++ b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+# Commit Date: 16 Apr 2014
+COMMIT="f2afd55704bfe0a2d66e6b270d247e9b8a7b1664"
+
+DESCRIPTION="vim plugin: collection of vimscripts for Haskell development"
+HOMEPAGE="https://github.com/dag/vim2hs"
+SRC_URI="https://github.com/dag/vim2hs/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/ghc"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ # We want a stripped-down version of these.
+ local f
+ for f in screenshots/*; do
+ bzip2 -9 "${f}" || die
+ done
+ vim-plugin_src_install
+}