summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2021-06-12 14:00:18 +0200
committerSam James <sam@gentoo.org>2021-06-12 12:54:54 +0000
commit91773fd1eb57d4c080c0151f5899f1631ddf2aac (patch)
treefbefa4cdaae4805460c949ba9004bd957d1fa1ec /dev-cpp/pystring/pystring-1.1.3-r1.ebuild
parentkde-plasma/plasma-meta: arm64 keyworded (diff)
downloadgentoo-91773fd1eb57d4c080c0151f5899f1631ddf2aac.tar.gz
gentoo-91773fd1eb57d4c080c0151f5899f1631ddf2aac.tar.bz2
gentoo-91773fd1eb57d4c080c0151f5899f1631ddf2aac.zip
dev-cpp/pystring: Don't use hardcoded g++ (convert to CMake)
Convert the project into cmake so we get compiler switching for free. Closes: https://bugs.gentoo.org/795156 Closes: https://bugs.gentoo.org/795168 Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21209 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/pystring/pystring-1.1.3-r1.ebuild')
-rw-r--r--dev-cpp/pystring/pystring-1.1.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-cpp/pystring/pystring-1.1.3-r1.ebuild b/dev-cpp/pystring/pystring-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..808484d4a233
--- /dev/null
+++ b/dev-cpp/pystring/pystring-1.1.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ functions matching the interface and behavior of python string methods"
+HOMEPAGE="https://github.com/imageworks/pystring"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/imageworks/pystring.git"
+else
+ SRC_URI="https://github.com/imageworks/pystring/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+BDEPEND="
+ virtual/libc
+ sys-devel/libtool
+"
+RESTRICT="mirror"
+
+LICENSE="BSD"
+SLOT="0"
+
+PATCHES=(
+ # Patch to convert the project into cmake. Taken from:
+ # https://github.com/imageworks/pystring/pull/29
+ "${FILESDIR}/cmake.patch"
+)