summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-22 06:20:24 +0100
committerSam James <sam@gentoo.org>2022-09-22 06:47:50 +0100
commit42096f4c7706533cf102332596a92c840ae7192f (patch)
treeee30a66f7355b93c69a415b0146ed94969d39193 /dev-cpp/tbb
parentdev-db/redis: add 7.0.5 (diff)
downloadgentoo-42096f4c7706533cf102332596a92c840ae7192f.tar.gz
gentoo-42096f4c7706533cf102332596a92c840ae7192f.tar.bz2
gentoo-42096f4c7706533cf102332596a92c840ae7192f.zip
dev-cpp/tbb: add 2021.6.0
Bug: https://bugs.gentoo.org/872287 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/Manifest1
-rw-r--r--dev-cpp/tbb/tbb-2021.6.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/tbb/Manifest b/dev-cpp/tbb/Manifest
index b048b94c2114..544f110b44ad 100644
--- a/dev-cpp/tbb/Manifest
+++ b/dev-cpp/tbb/Manifest
@@ -1,3 +1,4 @@
DIST tbb-2020.3.tar.gz 2639788 BLAKE2B 3e92bccdc8179fc049379ccbb8ad7f615623177abc61d813b1a601020c345137bfd7d4c4600cf5b0d587e5ebef677635c3c8124d06b05fdd3325128ed8c9f84a SHA512 04c4b5501418792827190691d03d20d4dc1fd3cbbcf459a4d40c5c2281d964e658f31f133ad3907b78e17ed04f4ff16728ed89487ed0ce2cb239f23feb34bd87
DIST tbb-2021.4.0.tar.gz 2452533 BLAKE2B a635c6efa1894c33e2f75c1aa03b6c0f4a86ebef3b58fa42bd25b53d661ed7a9d21f49f121dd3679735f219fbfc35604600bcc72ba60d3602e6de77b0d62e37b SHA512 96da2bc351fd64dfa854f8e6cabc1c4e53af3d55760e99d6f83ad53779c727af333d13d6be0828ed70371cf796498d2063e9dd0e4b2f6451623bb5d28ccbf20b
DIST tbb-2021.5.0.tar.gz 2463218 BLAKE2B 2d50d312b86318ba4923afe68753b3781f9646cbdb33861f3458301a3a19b7ca3aab6959dca085294dfc743d7f552635f80fb524ec5d780a46f58ffe02e3280d SHA512 0e7b71022e397a6d7abb0cea106847935ae79a1e12a6976f8d038668c6eca8775ed971202c5bd518f7e517092b67af805cc5feb04b5c3a40e9fbf972cc703a46
+DIST tbb-2021.6.0.tar.gz 2566074 BLAKE2B ec5d98d2890828323cefabc75011658d508eab531c9b30030162f6ce367c54a8d70d6c6611c00d93ab3ef041ea1af35f8180768e114611847547447545f70c71 SHA512 c28bd4045e3269d0d9c24dbf360f849d26eaa15e34fa9dd3f5feae0f3440ff74ab1d05154b95549a135e7d9e97fd9a7ff4b4e468b13265e0477bb58f47e856b6
diff --git a/dev-cpp/tbb/tbb-2021.6.0.ebuild b/dev-cpp/tbb/tbb-2021.6.0.ebuild
new file mode 100644
index 000000000000..8314a6dcb3c6
--- /dev/null
+++ b/dev-cpp/tbb/tbb-2021.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="High level abstract threading library"
+HOMEPAGE="https://www.threadingbuildingblocks.org"
+SRC_URI="https://github.com/oneapi-src/oneTBB/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/oneTBB-${PV}"
+
+LICENSE="Apache-2.0"
+# https://github.com/oneapi-src/oneTBB/blob/master/CMakeLists.txt#L53
+# libtbb<SONAME>-libtbbmalloc<SONAME>-libtbbbind<SONAME>
+SLOT="0/12.5-2.5-3.5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!kernel_Darwin? ( sys-apps/hwloc:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ # need to verify this is in master
+ "${FILESDIR}"/${PN}-2021.5.0-musl-mallinfo.patch
+ # musl again, should be in.. 2022?
+ "${FILESDIR}"/${PN}-2021.5.0-musl-setcontext.patch
+ "${FILESDIR}"/${PN}-2021.5.0-flags-stripping.patch
+)
+
+src_configure() {
+ # bug #872287
+ filter-flags -D_GLIBCXX_ASSERTIONS
+ append-cppflags -U_GLIBCXX_ASSERTIONS
+
+ local mycmakeargs=(
+ -DTBB_TEST=$(usex test)
+ -DTBB_ENABLE_IPO=OFF
+ -DTBB_STRICT=OFF
+ )
+
+ cmake-multilib_src_configure
+}