summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2024-10-08 05:33:46 -0400
committerFlorian Schmaus <flow@gentoo.org>2024-10-14 09:14:00 +0200
commit11790c99bb99d7b06e8eed57d37fde47bf5445a0 (patch)
tree3e40d70814cfa4e6548fb06959f56b0b7d4a97df /dev-cpp
parentprofiles/base: use mask abseil for dev-cpp/gtest (diff)
downloadgentoo-11790c99bb99d7b06e8eed57d37fde47bf5445a0.tar.gz
gentoo-11790c99bb99d7b06e8eed57d37fde47bf5445a0.tar.bz2
gentoo-11790c99bb99d7b06e8eed57d37fde47bf5445a0.zip
dev-cpp/gtest: fix running gtest_help_test test
Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gtest/files/gtest-1.15.2-fix-gtest_help_test.patch17
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild5
2 files changed, 21 insertions, 1 deletions
diff --git a/dev-cpp/gtest/files/gtest-1.15.2-fix-gtest_help_test.patch b/dev-cpp/gtest/files/gtest-1.15.2-fix-gtest_help_test.patch
new file mode 100644
index 000000000000..1ba087a53e39
--- /dev/null
+++ b/dev-cpp/gtest/files/gtest-1.15.2-fix-gtest_help_test.patch
@@ -0,0 +1,17 @@
+Similar to the bazel build, gtest is supposed to pass --has_absl_flags to
+gtest_help_test if building with abseil support but neglects to.
+
+--- a/googletest/CMakeLists.txt
++++ b/googletest/CMakeLists.txt
+@@ -293,7 +293,11 @@
+ py_test(googletest-filter-unittest)
+
+ cxx_executable(gtest_help_test_ test gtest_main)
++ if(NOT GTEST_HAS_ABSL)
+ py_test(gtest_help_test)
++ else()
++ py_test(gtest_help_test --has_absl_flags)
++ endif()
+
+ cxx_executable(googletest-list-tests-unittest_ test gtest)
+ py_test(googletest-list-tests-unittest)
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index be6392d028d6..f7916479456c 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -41,7 +41,10 @@ RDEPEND="${DEPEND}"
# Exclude tests that fail with FEATURES="usersandbox"
CMAKE_SKIP_TESTS=( "googletest-(death-test|port)-test" )
-PATCHES=( "${FILESDIR}"/gtest-find-re2-with-pkgconfig.patch )
+PATCHES=(
+ "${FILESDIR}"/gtest-find-re2-with-pkgconfig.patch
+ "${FILESDIR}"/gtest-1.15.2-fix-gtest_help_test.patch
+)
pkg_setup() {
use test && python-any-r1_pkg_setup