summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-28 22:07:19 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-28 22:14:48 -0500
commit2d7190383288b22de4e895fa98ef3fef4d8ebed9 (patch)
tree9660d52f70537643c1f7cf13ea2fc8b89c27eac8 /dev-cpp
parentmedia-sound/streamripper: Keyword 1.64.6 arm64, #920860 (diff)
downloadgentoo-2d7190383288b22de4e895fa98ef3fef4d8ebed9.tar.gz
gentoo-2d7190383288b22de4e895fa98ef3fef4d8ebed9.tar.bz2
gentoo-2d7190383288b22de4e895fa98ef3fef4d8ebed9.zip
dev-cpp/simpleini: add 4.21
CMakeLists.txt is now more usable (minus some quirks) and should probably be switched to in the future. But it changes the install location of the header and its only revdep (devilutionx) currently cannot find it. Could be solved with a 1 line sed/patch in devilutionx but will wait and stick to makefile for now to observe the situation. Will reconsider next simpleini and/or devilutionx bump. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/simpleini/Manifest1
-rw-r--r--dev-cpp/simpleini/simpleini-4.21.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/simpleini/Manifest b/dev-cpp/simpleini/Manifest
index e850a145f63c..fb19012e80da 100644
--- a/dev-cpp/simpleini/Manifest
+++ b/dev-cpp/simpleini/Manifest
@@ -1 +1,2 @@
DIST simpleini-4.20.tar.gz 64807 BLAKE2B 5179fbdc1a46b352590a20bcaafa88d905d75ef3334becc03caf11f5b8c4bd3673971d688f9ec0077af3192244b29befd217dfa4ef218594f68c917698727b72 SHA512 e2518d10d63026b0fd423cbd77372b60bc693e8ec1878a91ab05364a49b48d38d8d379247a27a8ffc5582ba19e333b10996f4bf48899c06c567ae0dea067a9e3
+DIST simpleini-4.21.tar.gz 65928 BLAKE2B 92b32ff2767dc7177ddc3a61fa122cc2810d99ff4be461adb88849ce92ff242899348bc55b698a31c30440e1e02efd9226c7a2075c4080c6b90874778bbf3d0c SHA512 a2bbe879f49c8e790daf3c5b02fbf7bacb0249a6d4b8b31116602c48090dc579c3d463b1288923ecd4708647ff2b47dee739a85bb47607d249d5608b29740011
diff --git a/dev-cpp/simpleini/simpleini-4.21.ebuild b/dev-cpp/simpleini/simpleini-4.21.ebuild
new file mode 100644
index 000000000000..ccc5bfadc70d
--- /dev/null
+++ b/dev-cpp/simpleini/simpleini-4.21.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C++ library providing a simple API to read and write INI-style files"
+HOMEPAGE="https://github.com/brofield/simpleini/"
+SRC_URI="https://github.com/brofield/simpleini/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+BDEPEND="test? ( virtual/pkgconfig )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.20-pkgconfig-var.patch
+)
+
+src_compile() {
+ if use test; then
+ tc-export CXX PKG_CONFIG
+ emake -C tests "${emakeargs[@]}"
+ fi
+}
+
+src_install() {
+ # note: this skips ConvertUTF, can use -DSI_CONVERT_ICU instead if needed
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}