summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-01 03:08:32 +0100
committerSam James <sam@gentoo.org>2022-04-01 04:53:43 +0100
commit492c8fdea4687ebf3faf8ee4163d5a2660449517 (patch)
treecfa70c2e056e1c906ea279211a312d7437468533 /dev-cpp
parentdev-util/watchman: drop 2022.02.28.00, 2022.03.07.00 (diff)
downloadgentoo-492c8fdea4687ebf3faf8ee4163d5a2660449517.tar.gz
gentoo-492c8fdea4687ebf3faf8ee4163d5a2660449517.tar.bz2
gentoo-492c8fdea4687ebf3faf8ee4163d5a2660449517.zip
dev-cpp/folly: drop 2022.02.28.00, 2022.03.07.00
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/folly/Manifest2
-rw-r--r--dev-cpp/folly/folly-2022.02.28.00.ebuild61
-rw-r--r--dev-cpp/folly/folly-2022.03.07.00.ebuild61
3 files changed, 0 insertions, 124 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
index 513994b2adfb..71801ebb7718 100644
--- a/dev-cpp/folly/Manifest
+++ b/dev-cpp/folly/Manifest
@@ -1,5 +1,3 @@
-DIST folly-2022.02.28.00.tar.gz 3600258 BLAKE2B 5943b0e4b6178c8293714f673ed289daed26b1dad22dcb52dc80475f385961cf0a690accc44139f245f2df5cf10c0bdb5638c8bed52cb97fefd3ad6d8dc147b8 SHA512 91ee21e463ffc6eee3b0e5e0244721a9612337b9afe92645556a154f521aec1070f4f381962247bb9bf11592efb5b8bb01f70d1a66acd3444967538062dfe826
-DIST folly-2022.03.07.00.tar.gz 3604306 BLAKE2B fe255678d6f827c82ada3e136742d07bd62dfb81c1250ca6bae9a4f3e1f015904032da8de1488342da1326fa520b448c63a59ef7e0139ecb0844a1ae19c1dfed SHA512 e63eff137711ca71b5a78469e4feff1b4e7b65465413eefb91b7c0cb26b94e1d581a305a9df9937ce05bcd8af3dc465adb816ad95538689811d8ab5b5b9f269f
DIST folly-2022.03.14.00.tar.gz 3605018 BLAKE2B 11a58e3c23c1e1299c16821e552d500f8215d2fb2fbdee3699b8487e1073196dfc322461e7670d3968c703d84b0b526d2479bcb74005b763f195ce48f04a419d SHA512 0b3710862360788eb55dc40703e3862f57819acf217287f13ce125b56692c4e5b1de12289f02520ecca9007fa872a69e8936df0ec9260adf974a88286489a9b1
DIST folly-2022.03.21.00.tar.gz 3611725 BLAKE2B 6b0d3431810a26484b2c15a8ba4b245e720d717364a4305269b3adabaa2d005466dfd7ad086b38cb06ee2a2d5908e903e68486aadc62834a32b4fe59cd313095 SHA512 4e0fda55f007179883af30024fe1d389642159b1b4c915f7ef1a3c1003c8c52e2370f53ffa79d5fa75533d33becfb946d2bcbb2abdc62b9a297f977403d13dd7
DIST folly-2022.03.28.00.tar.gz 3616507 BLAKE2B da003701abe599f20ac87a2785fe9a4cd4a8896d182737eb1eac6384f3d75a792225b426febea7cc4ea99aac1a1f31eb7330e0a297f43ae7d5aafccd93784560 SHA512 6eee07b3e82247c3c8672442503e9a69a1c4607604269fc0760e11a2d0e5595029e6995fbe7c970d2052a7f228f6b92112630e6d5c624369fc52e5ad1823ef74
diff --git a/dev-cpp/folly/folly-2022.02.28.00.ebuild b/dev-cpp/folly/folly-2022.02.28.00.ebuild
deleted file mode 100644
index b644181fecc6..000000000000
--- a/dev-cpp/folly/folly-2022.02.28.00.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog[gflags]
- dev-libs/boost:=[context,threads(+)]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- sys-libs/liburing:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )"
-# libiberty is linked statically
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs"
-BDEPEND="test? ( sys-devel/clang )"
-
-pkg_setup() {
- if use test && [[ ${BUILD_TYPE} != "binary" ]] && ! tc-is-clang ; then
- ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
- ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
-
- export CC=${CHOST}-clang
- export CXX=${CHOST}-clang++
- fi
-}
-
-src_configure() {
- # TODO: liburing could in theory be optional but fails to link
-
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
diff --git a/dev-cpp/folly/folly-2022.03.07.00.ebuild b/dev-cpp/folly/folly-2022.03.07.00.ebuild
deleted file mode 100644
index b644181fecc6..000000000000
--- a/dev-cpp/folly/folly-2022.03.07.00.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog[gflags]
- dev-libs/boost:=[context,threads(+)]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- sys-libs/liburing:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )"
-# libiberty is linked statically
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs"
-BDEPEND="test? ( sys-devel/clang )"
-
-pkg_setup() {
- if use test && [[ ${BUILD_TYPE} != "binary" ]] && ! tc-is-clang ; then
- ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
- ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
-
- export CC=${CHOST}-clang
- export CXX=${CHOST}-clang++
- fi
-}
-
-src_configure() {
- # TODO: liburing could in theory be optional but fails to link
-
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}