summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-09 19:39:52 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-09 19:39:52 +0100
commit5fda5b708d0d8122f070a784aea413cd13992207 (patch)
tree8d676ba34579004aa56d7ed64151575c4d1560a6 /dev-cpp
parentsys-apps/epoch: Drop 1.2.2 (diff)
downloadgentoo-5fda5b708d0d8122f070a784aea413cd13992207.tar.gz
gentoo-5fda5b708d0d8122f070a784aea413cd13992207.tar.bz2
gentoo-5fda5b708d0d8122f070a784aea413cd13992207.zip
dev-cpp/libglademm: update EAPI 5 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libglademm/libglademm-2.6.7-r3.ebuild (renamed from dev-cpp/libglademm/libglademm-2.6.7-r2.ebuild)33
1 files changed, 11 insertions, 22 deletions
diff --git a/dev-cpp/libglademm/libglademm-2.6.7-r2.ebuild b/dev-cpp/libglademm/libglademm-2.6.7-r3.ebuild
index 4b75e756ca7e..0a8fa5f985cd 100644
--- a/dev-cpp/libglademm/libglademm-2.6.7-r2.ebuild
+++ b/dev-cpp/libglademm/libglademm-2.6.7-r3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-GCONF_DEBUG="no"
+EAPI=8
+
GNOME_TARBALL_SUFFIX="bz2"
-inherit eutils flag-o-matic gnome2 multilib-minimal
+inherit gnome2 multilib-minimal
DESCRIPTION="C++ bindings for libglade"
HOMEPAGE="https://www.gtkmm.org"
@@ -20,9 +20,8 @@ RDEPEND="
>=dev-cpp/gtkmm-2.24.3:2.4[${MULTILIB_USEDEP}]
>=dev-cpp/glibmm-2.34.1:2[${MULTILIB_USEDEP}]
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
# we will control install manually in install
@@ -33,8 +32,6 @@ src_prepare() {
sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
Makefile.am Makefile.in || die "sed Makefile.{am,in} failed (2)"
- append-cxxflags -std=c++11 #566584
-
gnome2_src_prepare
}
@@ -45,30 +42,22 @@ multilib_src_configure() {
multilib_src_compile() {
gnome2_src_compile
- if multilib_is_native_abi && use doc; then
- emake -C "docs/reference" all
- fi
+ multilib_is_native_abi && use doc && emake -C docs/reference all
}
multilib_src_install() {
gnome2_src_install
- if use examples; then
- emake -C "examples" distclean
- fi
+ use examples && emake -C examples distclean
}
multilib_src_install_all() {
+ use doc && HTML_DOCS=( docs/reference/html/. )
einstalldocs
- if use doc ; then
- dohtml -r docs/reference/html/*
- fi
-
if use examples; then
- find "${S}/examples" -name "Makefile*" -delete \
+ find examples/ -name 'Makefile*' -delete \
|| die "examples cleanup failed"
- insinto "/usr/share/doc/${PF}"
- doins -r examples
+ dodoc -r examples
fi
}