summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-03 03:53:41 +0100
committerSam James <sam@gentoo.org>2024-08-03 03:53:41 +0100
commit7143daf875f4eadebb4f5789377af6fb79a14c97 (patch)
tree57929da0c95e98f4827621734d184ec32dcc5888 /dev-cpp
parentmedia-libs/woff2: fix build w/ gcc-15 (diff)
downloadgentoo-7143daf875f4eadebb4f5789377af6fb79a14c97.tar.gz
gentoo-7143daf875f4eadebb4f5789377af6fb79a14c97.tar.bz2
gentoo-7143daf875f4eadebb4f5789377af6fb79a14c97.zip
dev-cpp/cppdap: add 0_pre20240802
Fixes build w/ GCC 15. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cppdap/Manifest1
-rw-r--r--dev-cpp/cppdap/cppdap-0_pre20240802.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/cppdap/Manifest b/dev-cpp/cppdap/Manifest
index 7d1fa79cedcd..a52c87c660b9 100644
--- a/dev-cpp/cppdap/Manifest
+++ b/dev-cpp/cppdap/Manifest
@@ -1,2 +1,3 @@
DIST cppdap-0_pre20230605.tar.gz 100715 BLAKE2B a7b6f745b7445242544deb2cd5b93bb13ee0faefe083a5e435d9a608fb453aceef1746738beb35678833f69521e637f2b8ca47fccd3e292a56e8a74c6435df86 SHA512 034f6282e992ec346715f84da1817a699937be174ab0ea09f750a693bed158b87ec6920e0ed1f7340ef5232e9634c5aebccd78527adde34b8abc4ff00c5f617e
+DIST cppdap-0_pre20240802.tar.gz 101733 BLAKE2B 18302d37493ab38b579b0a00756e18efbaa1620e705e2bb54b24ccb3388837ea8aed28c880b358b670006f84ccb7df036125d1c2f7bb210ba51fa0caebef0759 SHA512 2432c2b413d956661342555a50ab2ed4cdf86de5e7bbda0822a2e7359ad034a0b0150bb6b98dff0d1a3d64e89cd8de67a7a620dd4c9e220a7ed1f9f80e5a36e6
DIST cppdap-gtest-0a03480824b4fc7883255dbd2fd8940c9f81e22e.tar.gz 874709 BLAKE2B 706e6d168e080494ac63cf607c189f55f5e98100fd744dd184a8217173f66891aedb8779a9c8b0aa289889d1f73e18c50ef65d8c70228e2a795a5e5081f66894 SHA512 55867a2e39647a7846506446d642dcd740711dee8c0dfe25887fd6ad361161617f3d462bdb415dfba20693849949c022e97e2de65dd731cc63b9466edd1c8b87
diff --git a/dev-cpp/cppdap/cppdap-0_pre20240802.ebuild b/dev-cpp/cppdap/cppdap-0_pre20240802.ebuild
new file mode 100644
index 000000000000..a590a1f1bc61
--- /dev/null
+++ b/dev-cpp/cppdap/cppdap-0_pre20240802.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+# See https://github.com/google/cppdap/issues/113 re no release
+CPPDAP_COMMIT="c69444ed76f7468b232ac4f989cb8f2bdc100185"
+
+DESCRIPTION="C++ library for the Debug Adapter Protocol"
+HOMEPAGE="https://github.com/google/cppdap"
+SRC_URI="https://github.com/google/cppdap/archive/${CPPDAP_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${CPPDAP_COMMIT}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-cpp/nlohmann_json"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ # Per README, could use rapidjson or jsoncpp instead.
+ -DCPPDAP_USE_EXTERNAL_NLOHMANN_JSON_PACKAGE=ON
+ -DCPPDAP_USE_EXTERNAL_RAPIDJSON_PACKAGE=OFF
+ -DCPPDAP_USE_EXTERNAL_JSONCPP_PACKAGE=OFF
+
+ -DCPPDAP_BUILD_TESTS=$(usex test)
+ -DCPPDAP_USE_EXTERNAL_GTEST_PACKAGE=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./cppdap-unittests || die
+}