summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-08-09 09:13:53 -0400
committerSam James <sam@gentoo.org>2024-08-09 14:24:00 +0100
commit79d5a2baf84f5a9086cf49095928bc9fb31cfb82 (patch)
treef00d3780f89a2218aba90fabe22604b8d5cd807d /dev-cpp
parentnet-nntp/nzbget: add 24.2 (diff)
downloadgentoo-79d5a2baf84f5a9086cf49095928bc9fb31cfb82.tar.gz
gentoo-79d5a2baf84f5a9086cf49095928bc9fb31cfb82.tar.bz2
gentoo-79d5a2baf84f5a9086cf49095928bc9fb31cfb82.zip
dev-cpp/json11: Fix compilation on GCC 15
Closes: https://bugs.gentoo.org/937530 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/38028 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/json11/files/json11-1.0.0-include-cstdint.patch12
-rw-r--r--dev-cpp/json11/json11-1.0.0-r1.ebuild3
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-cpp/json11/files/json11-1.0.0-include-cstdint.patch b/dev-cpp/json11/files/json11-1.0.0-include-cstdint.patch
new file mode 100644
index 000000000000..29648cf15825
--- /dev/null
+++ b/dev-cpp/json11/files/json11-1.0.0-include-cstdint.patch
@@ -0,0 +1,12 @@
+diff --git a/json11.cpp b/json11.cpp
+index 9647846..8266a14 100644
+--- a/json11.cpp
++++ b/json11.cpp
+@@ -22,6 +22,7 @@
+ #include "json11.hpp"
+ #include <cassert>
+ #include <cmath>
++#include <cstdint>
+ #include <cstdlib>
+ #include <cstdio>
+ #include <limits>
diff --git a/dev-cpp/json11/json11-1.0.0-r1.ebuild b/dev-cpp/json11/json11-1.0.0-r1.ebuild
index ab8457f641aa..66b400e6f1bd 100644
--- a/dev-cpp/json11/json11-1.0.0-r1.ebuild
+++ b/dev-cpp/json11/json11-1.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,4 +16,5 @@ KEYWORDS="amd64 x86"
PATCHES=(
"${FILESDIR}"/${P}-fix-multiarch-install.patch
"${FILESDIR}"/${PN}-1.0.0-json11.pc-do-not-state-the-defaults.patch
+ "${FILESDIR}"/${PN}-1.0.0-include-cstdint.patch
)