summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-06 17:32:30 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-06 17:39:06 +0200
commita3eb0357ac6c1b49af3fbe6d7be0533058042156 (patch)
tree98b08da5643602549d1a5bec2438d9cc027ba530 /dev-cpp
parentnet-mail/amavis-logwatch: new version 1.51.04. (diff)
downloadgentoo-a3eb0357ac6c1b49af3fbe6d7be0533058042156.tar.gz
gentoo-a3eb0357ac6c1b49af3fbe6d7be0533058042156.tar.bz2
gentoo-a3eb0357ac6c1b49af3fbe6d7be0533058042156.zip
dev-cpp/websocketpp: add 0.8.2
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/websocketpp/Manifest1
-rw-r--r--dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost_find_component.patch24
-rw-r--r--dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-clang.patch25
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.8.2.ebuild48
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/Manifest b/dev-cpp/websocketpp/Manifest
index f678a25e2e1c..a8ffad9db283 100644
--- a/dev-cpp/websocketpp/Manifest
+++ b/dev-cpp/websocketpp/Manifest
@@ -1 +1,2 @@
DIST websocketpp-0.8.1.tar.gz 699468 BLAKE2B e5769229b400d2f42e69541b07cfba17dcc82cdad20685a52ac1130c2fc4e94764a38d2e4f7c36101b11705e10c67eb149ba2c30750e7a6f63696d52c272fed2 SHA512 35e0261ed0285acf77d300768819bd380197de8acdf68223e2d7598481b9bfd69cb1653b435139771b1db6c16530c8d8cf9a887a8a6bba3fea126d0da4dbc13c
+DIST websocketpp-0.8.2.tar.gz 701364 BLAKE2B dacee33832f493d465afe208f9edea1393414a22c8db8f8c86b8f913521d0d8d68b95673a2e82b7479acfbab1ac541eda2d713a55d5de387b3879461d5884df7 SHA512 b2afc63edb69ce81a3a6c06b3d857b3e8820f0e22300ac32bb20ab30ff07bd58bd5ada3e526ed8ab52de934e0e3a26cad2118b0e68ecf3e5e9e8d7101348fd06
diff --git a/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost_find_component.patch b/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost_find_component.patch
new file mode 100644
index 000000000000..28f4361f35c1
--- /dev/null
+++ b/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost_find_component.patch
@@ -0,0 +1,24 @@
+From 36b73da8958927f975b3d01a062aa6c0e149d97f Mon Sep 17 00:00:00 2001
+From: Peter Thorson <git@zaphoyd.com>
+Date: Mon, 27 Apr 2020 10:34:06 -0500
+Subject: [PATCH] [cmake] Remove quotes that was making it hard for cmake to
+ find newer boost versions. fixes #855
+
+---
+ CMakeLists.txt | 2 +-
+ changelog.md | 3 +++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3e9c80e84..ffcd8583b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -215,7 +215,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
+ set (Boost_USE_MULTITHREADED TRUE)
+ set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
+
+- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
++ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
+
+ if (Boost_FOUND)
+ # Boost is a project wide global dependency.
diff --git a/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-clang.patch b/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-clang.patch
new file mode 100644
index 000000000000..2937ba71aced
--- /dev/null
+++ b/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-clang.patch
@@ -0,0 +1,25 @@
+From 2c355d9ef0f3ed73fa96d0c6c31293086df36d74 Mon Sep 17 00:00:00 2001
+From: Peter Thorson <git@zaphoyd.com>
+Date: Sun, 19 Apr 2020 22:33:24 -0500
+Subject: [PATCH] Fix typo in CMakeLists.txt that caused CXX_FLAGS to be
+ improperly quoted. Removed unnecessary hardcoded dependency on libc++ for
+ clang. fixes #859
+
+---
+ CMakeLists.txt | 2 +-
+ changelog.md | 3 +++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index dcf90d1c8..3e9c80e84 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -152,7 +152,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
+ endif()
+ set (WEBSOCKETPP_PLATFORM_TLS_LIBS ssl crypto)
+ set (WEBSOCKETPP_BOOST_LIBS system thread)
+- set (CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS} "-std=c++0x -stdlib=libc++") # todo: is libc++ really needed here?
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
+ if (NOT APPLE)
+ add_definitions (-DNDEBUG -Wall -Wno-padded) # todo: should we use CMAKE_C_FLAGS for these?
+ endif ()
diff --git a/dev-cpp/websocketpp/websocketpp-0.8.2.ebuild b/dev-cpp/websocketpp/websocketpp-0.8.2.ebuild
new file mode 100644
index 000000000000..3e9339f27dba
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.8.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="https://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/boost )"
+RDEPEND="dev-libs/boost"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-cmake-install.patch
+ # disable tests that are timing sensitive
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1461069
+ "${FILESDIR}"/${PN}-0.8.1-disable-test_transport-test_transport_asio_timers.patch
+ # https://github.com/zaphoyd/websocketpp/commit/36b73da8958927f975b3d01a062aa6c0e149d97f
+ "${FILESDIR}"/${P}-fix-boost_find_component.patch
+ # https://github.com/zaphoyd/websocketpp/commit/2c355d9ef0f3ed73fa96d0c6c31293086df36d74
+ "${FILESDIR}"/${P}-fix-clang.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CPP11=ON
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}