summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-30 18:28:09 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-08-02 22:57:07 +0100
commitf38838bb97d6bc421ad0fdf5dd52bde3147a0bc7 (patch)
treed1cf19b25a487aaf96ae54773c1ae6e6e5a0c6fa /dev-cpp
parentgames-engines/fheroes2: drop 1.1.0 (diff)
downloadgentoo-f38838bb97d6bc421ad0fdf5dd52bde3147a0bc7.tar.gz
gentoo-f38838bb97d6bc421ad0fdf5dd52bde3147a0bc7.tar.bz2
gentoo-f38838bb97d6bc421ad0fdf5dd52bde3147a0bc7.zip
dev-cpp/magic_enum: add 0.9.6
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37824 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/magic_enum/Manifest1
-rw-r--r--dev-cpp/magic_enum/files/magic_enum-0.9.6-werror.patch22
-rw-r--r--dev-cpp/magic_enum/magic_enum-0.9.6.ebuild31
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-cpp/magic_enum/Manifest b/dev-cpp/magic_enum/Manifest
index 8e0a5a0188ca..2825d06f5eed 100644
--- a/dev-cpp/magic_enum/Manifest
+++ b/dev-cpp/magic_enum/Manifest
@@ -1,2 +1,3 @@
DIST magic_enum-0.8.2.tar.gz 171915 BLAKE2B e8915aa7cafa9407d5d4ab3b6837fafde6b1cb75877c8b56f82568e6291ca317720950947b2dfc7e12ca459279ba4e809a8c5782fc04adc2d7636eddcb80122d SHA512 849c426484156faf91dde3f32f6c755c7698879b16dd83e13fb86b299b53ec9bbe4d55267581386302c8acb93d80ec044cc248371fdc8608cdd8f4ab12099f0a
DIST magic_enum-0.9.5.tar.gz 198269 BLAKE2B c3c6bbf6c5d366813dac7df5fbfc48f414cf4235d842ef3a5a2fd8f2c2857e55243b7fbf7000d598e778fc8d2d54c7d6e34f8a97fa2eaf510572bf53f17500a6 SHA512 f1b412d15e0ef624b4588adba00a18ed12eeb1f0dabc021d53a7c047b8976ecb07701b76040f47c77c75e00151619dbce1f9a75f471db04340156a39044768f3
+DIST magic_enum-0.9.6.tar.gz 199883 BLAKE2B 32909c5ea0cff32b14fb4fd5507f1f99cd45f572d56fd14f76aea3ca3c1fa16d08573568a7c7f9a3efbc9396450b2e897aa64de414b34a4c19b6c49f63aed506 SHA512 6154c816446e115f3b164df79ab8d8088eb76b632ee3fdc82ea17cc7ae8d04652c83e5cc587c2c4b334889904b101ba08a04c5837103af260768e93df17cc263
diff --git a/dev-cpp/magic_enum/files/magic_enum-0.9.6-werror.patch b/dev-cpp/magic_enum/files/magic_enum-0.9.6-werror.patch
new file mode 100644
index 000000000000..581df69ff82b
--- /dev/null
+++ b/dev-cpp/magic_enum/files/magic_enum-0.9.6-werror.patch
@@ -0,0 +1,22 @@
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -12,7 +12,7 @@
+ check_cxx_compiler_flag(/std:c++latest HAS_CPPLATEST_FLAG)
+ elseif(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+ set(CMAKE_VERBOSE_MAKEFILE ON)
+- set(OPTIONS -Wall -Wextra -Wshadow -pedantic-errors -Werror)
++ set(OPTIONS -Wall -Wextra)
+
+ check_cxx_compiler_flag(-std=c++20 HAS_CPP20_FLAG)
+ check_cxx_compiler_flag(-std=c++23 HAS_CPP23_FLAG)
+--- a/example/CMakeLists.txt
++++ b/example/CMakeLists.txt
+@@ -2,7 +2,7 @@
+
+ set(CMAKE_CXX_STANDARD 17)
+ if((CMAKE_CXX_COMPILER_ID MATCHES "GNU") OR (CMAKE_CXX_COMPILER_ID MATCHES "Clang"))
+- set(OPTIONS -Wall -Wextra -Wshadow -pedantic-errors -Werror)
++ set(OPTIONS -Wall -Wextra)
+ elseif(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
+ set(OPTIONS /W4 /WX)
+ if(HAS_PERMISSIVE_FLAG)
diff --git a/dev-cpp/magic_enum/magic_enum-0.9.6.ebuild b/dev-cpp/magic_enum/magic_enum-0.9.6.ebuild
new file mode 100644
index 000000000000..5a4a0dda0b76
--- /dev/null
+++ b/dev-cpp/magic_enum/magic_enum-0.9.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# As of 0.8.2, it has meson, but only for subproject use(?)
+# Doesn't install anything.
+inherit cmake
+
+DESCRIPTION="Static reflection for enums in header-only C++"
+HOMEPAGE="https://github.com/Neargye/magic_enum"
+SRC_URI="https://github.com/Neargye/magic_enum/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-werror.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAGIC_ENUM_OPT_BUILD_TESTS=$(usex test)
+ -DMAGIC_ENUM_OPT_INSTALL=ON
+ )
+
+ cmake_src_configure
+}