summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-10-14 20:38:01 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-18 08:25:39 +0300
commit8a5ef1976264fa06c9f14c3a72304a678b1be182 (patch)
treed8628919cf30284db3bba3dfa6ce7047e9f2aa93 /dev-db/mysqltuner/mysqltuner-1.7.17.ebuild
parentnet-mail/mu: drop 1.3.3 (diff)
downloadgentoo-8a5ef1976264fa06c9f14c3a72304a678b1be182.tar.gz
gentoo-8a5ef1976264fa06c9f14c3a72304a678b1be182.tar.bz2
gentoo-8a5ef1976264fa06c9f14c3a72304a678b1be182.zip
dev-db/mysqltuner: bump to 1.7.17
Version bump to 1.7.17. Drop password.patch. Closes: https://bugs.gentoo.org/696562 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Closes: https://github.com/gentoo/gentoo/pull/13301 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/mysqltuner/mysqltuner-1.7.17.ebuild')
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.7.17.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/mysqltuner-1.7.17.ebuild b/dev-db/mysqltuner/mysqltuner-1.7.17.ebuild
new file mode 100644
index 000000000000..f9caa472df48
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.7.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=MySQLTuner-perl
+
+DESCRIPTION="MySQLTuner is a high-performance MySQL tuning script"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/mysql
+ virtual/perl-Getopt-Long"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( USAGE.md CONTRIBUTING.md INTERNALS.md basic_passwords.txt vulnerabilities.csv )
+
+src_install() {
+ einstalldocs
+
+ newbin "${PN}.pl" "${PN}"
+
+ # Passwords and vulnerabilities are meant to be fed
+ # to the script uncompressed.
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}