summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 09:24:26 +0100
committerSam James <sam@gentoo.org>2023-04-18 09:24:26 +0100
commit36c975680bcd8b5605d8aa491bcad0c94dc14a06 (patch)
tree40766f956a6bf20d5b43360158698ef14ac00609 /dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
parentsci-libs/hdf5: add 1.14.0 (diff)
downloadgentoo-36c975680bcd8b5605d8aa491bcad0c94dc14a06.tar.gz
gentoo-36c975680bcd8b5605d8aa491bcad0c94dc14a06.tar.bz2
gentoo-36c975680bcd8b5605d8aa491bcad0c94dc14a06.zip
dev-db/percona-server: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895700 Closes: https://bugs.gentoo.org/895236 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild')
-rw-r--r--dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild b/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
index 6cda9fcd379e..4548b9b63299 100644
--- a/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
+++ b/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
@@ -47,7 +47,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -riscv ~s390 ~sparc ~
# and we will run a mysql server during test phase
S="${WORKDIR}/mysql"
-# Be warned, *DEPEND are version-dependant
+# Be warned, *DEPEND are version-dependent
# These are used for both runtime and compiletime
# openldap < dep for bug #835647 (we need ldap_r)
COMMON_DEPEND="
@@ -177,6 +177,7 @@ src_unpack() {
src_prepare() {
eapply "${WORKDIR}"/mysql-patches
eapply "${FILESDIR}"/${PN}-8.0.26.16-gcc-12.patch
+ eapply "${FILESDIR}"/${PN}-8.0.26.16-gcc-13.patch
# Avoid rpm call which would trigger sandbox, #692368
sed -i \
@@ -252,6 +253,7 @@ src_configure() {
# all the time for simplicity and to make sure it is actually correct.
-DSTACK_DIRECTION=$(tc-stack-grows-down && echo -1 || echo 1)
-DCMAKE_POSITION_INDEPENDENT_CODE=ON
+ -DUSE_LD_LLD=OFF
-DWITH_CURL=system
-DWITH_BOOST="${WORKDIR}/boost_$(ver_rs 1- _ ${MY_BOOST_VERSION})"
-DWITH_ROUTER=$(usex router ON OFF)