summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-07 07:43:53 +0000
committerSam James <sam@gentoo.org>2024-01-07 07:44:28 +0000
commite24b8b28cee24069a2314fdf0272a4f840358316 (patch)
tree1b612d3947a677c649d4472f5b929dfed27e8f3a /dev-db
parentdev-db/mongodb: fix indentation (diff)
downloadgentoo-e24b8b28cee24069a2314fdf0272a4f840358316.tar.gz
gentoo-e24b8b28cee24069a2314fdf0272a4f840358316.tar.bz2
gentoo-e24b8b28cee24069a2314fdf0272a4f840358316.zip
dev-db/mongodb: drop USE=lto
As noted in the bug (and this is why we're removing it in general unless it's useful), it has confusing semantics if the user passes -flto in their *FLAGS. After inspecting the upstream build system, the LTO build option which USE=lto wires up does nothing useful, so drop it. Closes: https://bugs.gentoo.org/915081 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mongodb/mongodb-4.4.20.ebuild5
-rw-r--r--dev-db/mongodb/mongodb-5.0.16-r1.ebuild3
2 files changed, 3 insertions, 5 deletions
diff --git a/dev-db/mongodb/mongodb-4.4.20.ebuild b/dev-db/mongodb/mongodb-4.4.20.ebuild
index 4dc301c49f07..fec625caa508 100644
--- a/dev-db/mongodb/mongodb-4.4.20.ebuild
+++ b/dev-db/mongodb/mongodb-4.4.20.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,7 +21,7 @@ SRC_URI="https://fastdl.mongodb.org/src/${MY_P}.tar.gz"
LICENSE="Apache-2.0 SSPL-1"
SLOT="0"
KEYWORDS="amd64 ~arm64 -riscv"
-IUSE="debug kerberos lto ssl test +tools"
+IUSE="debug kerberos ssl test +tools"
RESTRICT="!test? ( test )"
RDEPEND="acct-group/mongodb
@@ -123,7 +123,6 @@ src_configure() {
use arm64 && scons_opts+=( --use-hardware-crc32=off ) # Bug 701300
use debug && scons_opts+=( --dbg=on )
use kerberos && scons_opts+=( --use-sasl-client )
- use lto && scons_opts+=( --lto=on )
use ssl && scons_opts+=( --ssl )
# Needed to avoid forcing FORTIFY_SOURCE
diff --git a/dev-db/mongodb/mongodb-5.0.16-r1.ebuild b/dev-db/mongodb/mongodb-5.0.16-r1.ebuild
index 887fc03dafc2..736c9288f5fd 100644
--- a/dev-db/mongodb/mongodb-5.0.16-r1.ebuild
+++ b/dev-db/mongodb/mongodb-5.0.16-r1.ebuild
@@ -22,7 +22,7 @@ LICENSE="Apache-2.0 SSPL-1"
SLOT="0"
KEYWORDS="amd64 ~arm64 -riscv"
CPU_FLAGS="cpu_flags_x86_avx"
-IUSE="debug kerberos lto mongosh ssl +tools ${CPU_FLAGS}"
+IUSE="debug kerberos mongosh ssl +tools ${CPU_FLAGS}"
# https://github.com/mongodb/mongo/wiki/Test-The-Mongodb-Server
# resmoke needs python packages not yet present in Gentoo
@@ -138,7 +138,6 @@ src_configure() {
use arm64 && scons_opts+=( --use-hardware-crc32=off ) # Bug 701300
use debug && scons_opts+=( --dbg=on )
use kerberos && scons_opts+=( --use-sasl-client )
- use lto && scons_opts+=( --lto=on )
use amd64 && ! use cpu_flags_x86_avx && scons_opts+=( --experimental-optimization=-sandybridge ) # Bug 890294
scons_opts+=( --ssl=$(usex ssl on off) )