summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@ngg.hu>2022-03-13 11:12:10 +0100
committerZac Medico <zmedico@gentoo.org>2022-03-13 08:53:28 -0700
commit9ba3bd16cf3d906bfe65552ce5fa18e59553c304 (patch)
treeaa56009354e47793510fe8bd9cf1ee5b5bb95671 /dev-dotnet
parentdev-dotnet/dotnet-sdk-bin: bump to 5.0.406 (diff)
downloadgentoo-9ba3bd16cf3d906bfe65552ce5fa18e59553c304.tar.gz
gentoo-9ba3bd16cf3d906bfe65552ce5fa18e59553c304.tar.bz2
gentoo-9ba3bd16cf3d906bfe65552ce5fa18e59553c304.zip
dev-dotnet/dotnet-sdk-bin: bump to 6.0.201
Closes: https://github.com/gentoo/gentoo/pull/24534 Signed-off-by: Gergely Nagy <ngg@ngg.hu> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.201.ebuild58
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
index 76bc6ea81b93..19d8202366f0 100644
--- a/dev-dotnet/dotnet-sdk-bin/Manifest
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -22,3 +22,6 @@ DIST dotnet-sdk-6.0.101-linux-x64.tar.gz 173671008 BLAKE2B 340ddcfae67f2bbe4dd91
DIST dotnet-sdk-6.0.102-linux-arm.tar.gz 169190305 BLAKE2B 4f3aa3e2de89f8c360505c4287207bc285090f79e808e8b7637a3e92bbaaf69a6ea12c7296dfb729cb56a6c6e226ee276ff5e8776b439c140aeab5bcedd05824 SHA512 a72a0e81c62478b0dc662ef0aaeb7f96e7dd534e90b3ac1bdab1ca98dd93a4605881dba6e9ed2315781fdf71f5b33acb1aa5e28090c7a1693405bebed5853094
DIST dotnet-sdk-6.0.102-linux-arm64.tar.gz 167109725 BLAKE2B e687b702ce7e2ad5f8abf87eb63716c2e29880b9fa8c10f37ede05f2d59f2426433549a8d535b71f7243f698a014871b6f2de8a2c2b06600bbe8a74fbdb4a8c5 SHA512 790cbf322ca8fed32eaf574f19d0bdc05656c5a88a65aa4dba8269cfce1443cd7cdeecdd3a40e353c368f055490b70592ca7f15f981a66c5b3a9517d0b09e4cb
DIST dotnet-sdk-6.0.102-linux-x64.tar.gz 173139326 BLAKE2B cac49a69635c4f90bafc8e04b42c36e3196f6af8c39da152f16d771a3eff56fa39271c4af441a687cd9189031f6c68de3063a17aa1d21bc303a8172980c802de SHA512 edd79ebad3327032ea0aaa8504c14e3270050bb459b098202676776b41a3a1d282aaefd1e5e8aa09ef7f7cf7c4601c4783a57112ff6e3d427507e8eec2bfb748
+DIST dotnet-sdk-6.0.201-linux-arm.tar.gz 172378853 BLAKE2B 46424de89db998dd64696e8c9bc9d421280a1f87e4af100702cdab8a5995f26c6bbe26b4e5e10fdd04b357ad2ac70cdf8e00eaa60ac89c20b75aa4b621492a64 SHA512 5a683430325a90dd1d8e0071a1868939fb01268f9eb389ca1dc40956fde6b9f45bec086553ad3333139e530dfe5afae48195bcdfec388b0b568989924a1f1dd7
+DIST dotnet-sdk-6.0.201-linux-arm64.tar.gz 170314335 BLAKE2B 609c2487288982e191f7b2bb795219d44d789311873278a6d75fb72936211530ee21330942b8bf3ab239f752d62f36073da518cbf59f9c4a0dc48fc3f3911a17 SHA512 2ea443c27ab7ca9d566e4df0e842063642394fd22fe2a8620371171c8207ae6a4a72c8c54fc6af5b6b053be25cf9c09a74504f08b963e5bd84544619aed9afc2
+DIST dotnet-sdk-6.0.201-linux-x64.tar.gz 176562201 BLAKE2B 842b0483689a2efc66825ae8bc0b074532c26072869d25ceac6e9fd0fcd2814361a840920483c4199e8a30040048e953b31a3c215047d8f0ba77d45760d605f4 SHA512 a4d96b6ca2abb7d71cc2c64282f9bd07cedc52c03d8d6668346ae0cd33a9a670d7185ab0037c8f0ecd6c212141038ed9ea9b19a188d1df2aae10b2683ce818ce
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.201.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.201.ebuild
new file mode 100644
index 000000000000..237308fc0fc2
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.201.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="6.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/zlib:0/1
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:3.1[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
+ )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ # 6.0.100 is SDK feature band which will not change between minor increases, so 6.0.101, 6.102
+ # will still have same 6.0.100 SDK feature band in the name. Thus I have to hard code this
+ # https://github.com/dotnet/sdk/pull/18823#issuecomment-915603684
+ local workloads="metadata/workloads/${SLOT}.100"
+
+ { mkdir -p "${S}/${workloads}" && touch "${S}/${workloads}/userlocal"; } || die
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}