summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-08-06 16:34:31 +0200
committerJakov Smolić <jsmolic@gentoo.org>2024-08-06 16:35:48 +0200
commitd92190a93b9a880a5a7fadf1dff5c89fb10a8aed (patch)
treed09fe053cc8793172af659da793bfe30a94e014f /dev-embedded
parentdev-embedded/u-boot-tools: Add a missing dependency (diff)
downloadgentoo-d92190a93b9a880a5a7fadf1dff5c89fb10a8aed.tar.gz
gentoo-d92190a93b9a880a5a7fadf1dff5c89fb10a8aed.tar.bz2
gentoo-d92190a93b9a880a5a7fadf1dff5c89fb10a8aed.zip
dev-embedded/u-boot-tools: Install the mkeficapsule binary
Previous commit added the missing gnutls dependency for this binary and since we are already building it let's install it as well. Revbump for these changes and add util-linux as a dependency as mkeficapsule links to its library. Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2024.01-r1.ebuild (renamed from dev-embedded/u-boot-tools/u-boot-tools-2024.01.ebuild)3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2024.01.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2024.01-r1.ebuild
index 968110756c2a..1e13270fe5ad 100644
--- a/dev-embedded/u-boot-tools/u-boot-tools-2024.01.ebuild
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2024.01-r1.ebuild
@@ -23,6 +23,7 @@ IUSE="envtools"
RDEPEND="
dev-libs/openssl:=
net-libs/gnutls:=
+ sys-apps/util-linux:=
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -79,7 +80,7 @@ src_install() {
cd tools || die
if ! use envtools; then
- dobin dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
+ dobin dumpimage fdtgrep gen_eth_addr img2srec mkeficapsule mkenvimage mkimage
fi
dobin env/fw_printenv